"x-openai-isConsequential" flag not working

Hi everyone,

One of my action’s endpoints is a POST endpoint that is run for every user message sent.

It isn’t a consequential action so I added the “x-openai-isConsequential” flag and set it to false as so:

    "/v1/post_endpoint_name": {
      "post": {
        "x-openai-isConsequential": false,
        "description": "Action Description",

Even after adding this flag(and checking that it was saved), users don’t see the “always allow” button even and need to explicitly allow every action call.

Anyone run into this?

1 Like

I have the same problem, but I am not sure that you can update the json spec. It seems like OpenAI has some bug in the UI for that. Probably deleting it and adding it again seems to be the only way to “edit” it.

1 Like

Yes, action update is not stabile. Every time you need to delete/add action.
It is also solution for Error saving draft error

2 Likes

Yeah i’ve had same issue.

This looks promising, will try today.

this worked very well. Implemented on three different GPTs and they all now show “Always Allow” populate. Thanks for the guidance!

1 Like

Another thing that worked for me was

  1. Moving the to x-openai-isConsequential directly below the operation id
  2. Ensuring my operation ids only have alphanumeric names

I followed this based on the docs https://platform.openai.com/docs/actions/consequential-flag

3 Likes