Wrong email when trying to upgrade to plus suscription

Hi, a few hours ago I tried to upgrade to a plus subscription. But before I committed my details I saw that the emailadres was unrelated to my account. When I tried again a bit later to see what would happen, it did fill in my email correctly.

I filled in my credit card info into the forms, I just didn’t commit the upgrade. Is this a known bug? What could be the cause of this? Should I be concerned? I think if there was an insecure or wrong connection my browser would’ve complained. I used the link that I always use.

Thank you for posting this! The same exact thing happened to me around noon today when chatGPT became overwhelmed with traffic and crashed, and was down for a few hours. chatGPT started acting very strange. I tried to upgrade and noticed that the email field was pre-populated with someone else’s email just like you described. I tried it again and it used my correct email. I first wondered if someone had been on my machine. But I’m guessing that this strange behavior was due to the app trying to run in uncharted territory with low or no system resources, too much traffic etc. Programs can become extremely unpredictable right before they crash and they are running out of system resources. The extreme conditions may have just exposed a bug. I would like to learn more about this however. Thanks again for posting