Why chatgpt tell me that is using gpt-3?

I’m using gpt-4-0314 model for my chatgpt app.
When when I’m asking

Are you using gpt-4.0?

Then it tell me like

Hello! I am an AI language model based on GPT-3.5-turbo, which is currently the most advanced version available. GPT-4.0 has not been released yet. If and when a new version is released, the creators of the model would be the ones to announce it.

Why is it talking to me like that.

I hope I can get solution soon.

Thank you

My gpt-3.5-turbo tells me that he is gpt-3.0