Unable to get a streaming Response from ChatGPT

I test Chrome/Edge/Firefox, all of them prompt this same error

Same bug, started 20 minutes ago. Offered solutions don’t work. MacOS, both Chrome and Firefox.

DIDN’T HELP:

  1. Disabling ipv6 (Link local only in MacOS settings)
  2. Disabling ipv6 in Firefox’s about:config

WHAT HELPED (KIND OF) IN 60% OF CASES:

  1. Create new chat, send anything to it e.g. "openai devs suck "
  2. It hangs
  3. Refresh
  4. On the left, there’s a new chat “OpenAI devs struggle” with the response
  5. Continue in this chat normally. NOTE: it still returns the “Failed to execute ‘getReader’ on ‘ReadableStream’” error and still hangs sometimes. But often it works.

I was having this problem, and am using firefox (a fork of firefox, to be specific) on Windows 11. I had already disabled adblockers and noscript, but now I also disabled the built in firefox “advanced tracking protection” for the chatgpt page and it seems to be fixed.

I’m having the same issue with macOS and Chrome…

Same issues on all browsers in Ubuntu 23.10 (firefox, chromium, chrome). I think it has something to do with routes, as it only happens when i am on VPN, logged in with another account. Because on the account without VPN i didn’t notice this problem a single time

I tried all the methods that everyone said were useless, so I posted a bug message. No one replied to lol!!

Solved ! ! !
I had the same problem as you guys and I also tried to disable ipv6 but it didn’t solve it, the final solution was to fix my socks ports, maybe you guys should make sure your socks protocol ip ports are correct!

1 Like

Great. But how to “fix socks ports”?

Are your system’s environment variables regarding proxies set correctly? You can check this first, if the value of this variable is not consistent with the ip and port of your proxy server, you may “fix socks ports” ,which variables in Ubuntu is “all_proxy”.

1 Like

Solved!!! “fix socks port” works! You’re my hero!!! I have endured this bug for a month :sob: :sob: :sob:

open the developer panel in browser,then switch to network tab, to check the ‘disable cache’ option,it resolved my issues about this topic.

firefox: diable enhanced tracking protection fixed it.

For anyone who is using a ssh tunnel as proxy (established with ssh -TNf -D 127.0.0.1:proxy-port user@proxy-ip). This command starts ONLY socks proxy, no http/https proxy. So you have to set correct ‘proxy protocol’ like this (in Switchy Omega Chrome extension):

request URL:

https://ab.chatgpt.com/v1/rgstr

request method:

OPTIONS

Status Code:

403 Forbidden

Referrer Policy:

strict-origin-when-cross-origin
this is what the error(mark in red) is , can you help me resolve it?(maybe it is the key of the problem)thanks a lot

Because https://ab.chatgpt.com/v1/rgstr is getting a 403, the page halts in Firefox. Any news on this?