Unable to Attach Files to Vector Store

Issue; Unable to attach uploaded file to vector store

Description;

After uploading a file, and receiving confirmation that the file is uploaded, performing the http call to attach the file to a vector store by file_id results in a ‘failed’ status from the vector store 100% of the time

How to recreate

Below is the sample call chain that we’re using;
These are all performed via. the API

1. Create new vector store
2. Upload file(s)
3. Attach File to Vector Store
4. Attach Vector Store to Assistant
5. Perform work with assistant
6. Delete Files 
7. Delete Vector Store

We’ve tried placing arbitrary delays between steps 2 and 3 to no avail.

We’ve tried to upload the file directly to a Vector Store via the website, which also fails.

We’re attempting to attach pdf files.

Information Gained So Far

  1. When selecting File Search feature while using the Assistant in the playground, and uploading the same PDF that we’re using via the API, we notice that the automatically created vector store also has the pdf associated with a ‘fail’ status.
  2. When an image is uploaded, via the ‘upload image’ feature of the Assistant playground, and the same prompts are used, the assistant operates successfully, however, no vector store is used for the image. It simply exists as an uploaded file