Strange prompt merging/mixing

Over the past day’s I’ve encountered some strange behavior with the gpt-4 model. For unknown reasons separate prompts seem to merge, into a singular one after a while. Leading to essentially the entire conversation thread being merged into a mega prompt, that necessitates to delete the entire conversation and restart. As no responses can be generated from that one, nor can it be edited.

Oddly enough, this seems to only persist on PC based browsers, as my phone gpt app remains unaffected.

8 Likes

I also have this problem. Have had it for a few days.
I think I have figured out what is occurring even if nothing I do fixes it.

1. The prompt goes through and a response is generated.
2. Even though a response was generated, it doesn’t save.
3. If you reload the page, you can tell it didn’t go through as it just says the whole “There was an error generating a response” thing, alongside the regenerate button.
4. So since this response didn’t save, if you try to do another prompt the last prompt, since it failed to generate a response, it will just fuse with the new prompt.
5. the cycle continues.

IS how I think it works.

1 Like

Yes, thats precisely whats happening! Though, I would like to also add the fact that there is another sign to identify it, namely that it doesn’t generate a name for the chat and just leaves it as “new chat”.

Its a maddening issue, though the 3.5 model is somehow unaffected.

Hi!
I tried to find a workaround for this but never got any feedback.
Maybe you can help me out here?

https://community.openai.com/t/fusing-prompts-not-sure-but-the-prompts-keep-fusing-together/612029/11?u=vb

I have been keeping a look at my IDs. They’re all good. When I ask ChatGPT to answer something, sometimes the response will not save. So when I asked ChatGpt to tell me about eagles. That response about eagles did not save. And when I asked again IN THE SAME TAB to tell me about vultures, it fused with the prompt about eagles because the response about eagles didn’t save.

I have found a temporary solution of just refreshing the tab every time on response generation but it doesn’t help that it seems to be 50/50 on whether or not the response saves and I don’t have to regenerate a response again and it is wasting my 40 uses.

3 Likes

Oh GPT-4 in the browser, my prompts will fuse together for some reason and so the GPT thinks it has responded to my last prompt, plus this one so it confuses it. It is really odd, and it is throwing me off and wasting my 40 uses.

Hi!
That sounds like an annoying bug.
Can you share a link to a conversation as I am not sure what this actually looks like.

I’ll explain it, it’s happening to me. It might be resolved, it might not, but I’m going to refrain from using it for a bit. If it resolved, it’s because I have delete browser cache enabled on closing browser.

So I make a statement/question, it responds, I respond. This back and forth continues, but it keeps repeating itself somewhat, as if I just made my first statement. Not progressing. I decided to hard refresh the page. All of the things it has said are gone, and everything I said, is in one response, like everything I said was all at once, and not a back and forth.

Every newline you see, was not a new line, it was a response I had to a response it had. So all my different submissions kept being merged as one, and wasn’t showing this in the U.I, until I did a log out refresh and login. Which now makes sense why it wasn’t getting new context.

1 Like

Thanks for taking the time to explain.
What a random bug!
Also, thanks for printing your workarounds.

It seems to be happening again. Are you someone that’s able to drill into the situation?
Upon clearing my browser cache and logging back in, it now says that it’s using chatgpt 3.5, when I was using 4. I did not hit the limit that I know of. I had just started the thread and was about 6 messages deep. All the chats started today were titled “new chat”. So I tried checking it on my phones chatgpt app, sometimes it had allowed me to restate it should be chatgpt4 in the past and the browsers webui would take the update. But this time it didn’t, it just stayed at 3.5. But, the webui thread titles all changed from “new chat”, to an actual title that was relevant.


Here it is. A sample regardless but this always happens. I can make it respond and then it just acts like I never asked anyone anything and then fuses the prompts together.

I truly have no idea what is causing this

1 Like

I see one of those annoying but pretty much randomly occuring error messages but no prompt fusion as the two texts about eagles and vultures appear to be as expected.

In the past when I had issues with too many errors messages I did log-out and changed the IP, either via VPN or by disconnecting and reconnecting my router.

I think you have misinterpreted me. The prompt responds that the eagles and vultures, no longer exist. I took screenshots of them on the same tab they were generated in. But when I close it, and reopen it, they fuse and delete the responses that I asked for. This is all that is happening.

1 Like

Thanks for explaining this again.

What I see is that all three conversations have the same conversation-id. The conversation is the long number-letter string in the URL. In this case ending with 14ff01.

I expected the the vultures and eagles conversation have two different IDs. Or, in the case of you rewriting the initial message, that there is the little arrow symbol where one can switch between the different prompts.

Now, the third message has the same conversation-id and that’s when your prompts get fused into a single message and apparently the UI or the model don’t know what to do with that either.

Suggestion: when starting a new conversation, make sure you have a new conversation-id.
This should help, but I am aware that it’s not a solution in the strict sense.

I’ve started a new conversation and made sure it has a new conversation id, I even refreshed the page to make sure it does in fact save the response. And it did, in fact work as expected.

The problem however is that any subsequent prompts aren’t saved, and start fusing. This appears to be random, and just being persistent and reloading the page over and over till it works seems to be the only workaround I can find.

Which of course burns trough my message limit quite quickly.

3 Likes

I would have been more happy to read that the workaround works but it is what it is.
If you agree, I would like to merge the two topics that deal with the same issue in the hope to find more users who have the same issue.
Maybe we can push this bugfix ticket a little bit higher in the priority queue.

@sjoe2004

Yes, you can fuse the topics. I would also like a fix.

2 Likes

Just began happening to me too, but i noticed that it happens more when i’m somewhere with slow internet, and when i’m at home/somewhere with fast internet, it doesn’t happen as much.