[SOLVED] Custom action failed before sending when including a certain property

UPDATE: This morning I noticed that the schema changes were missing, and evidently while changes to the schema appeared to have been made and had persisted when going in and out of the schema editor, the change was just in the UI. This was consistent with behaviour and what I suspected, but the UI was showing the changes so took that at face value. Doing all of deleting the action, ensuring the schema version was updated and creating a new action seemed to get the change to stick.

I created a GPT and an action, which initially was sending two short string properties in a JSON payload to an endpoint, “name” and “date”. I updated the schema to include a 3rd property “notes”, which would be a longer string of maybe a few 100 characters. All three properties were marked as required in the schema. GPT crafted the json perfectly, but failed to contact the endpoint (it never tried). It then tried again without the notes property and succeeded. I deleted the action and recreated with the same schema, and same problem. I asked GPT to send a short dummy string instead to explore if it was content related, but then the notes property was never included. I asked it to send “ABCDE” for the notes property, but then hit the conversation limit to couldn’t test that yet.

Could there be a bug where updating a schema of an action doesn’t get handled correctly somewhere, or is there a limit on the size of data that can be posted, even though it has been crafted completely. Or, is there any other kind of preflight checking on data that is about to be sent to an endpoint beyond schema validation that could cause the request to be vetoed?