Problem in first project using OpenAi api

I try to run my first project that translate text using VS2022 ide
I copy a sample code form

and sure enter me api key that i got .
When i try to run the project i got on the console screen an error

code: TooManyRequests. Content: {
“error”: {
“message”: “You exceeded your current quota, please check your plan and billing details. For more information on this error, read the docs:”,
“type”: “insufficient_quota”,
“param”: null,
“code”: “insufficient_quota”
I try to create other key but the some result
what can i do about it ?
Regards Doron


Did you top up your balance? Check your usage you don’t have any quota.

1 Like

Yeah, fluxtah is certainly right. You can check your usage here →

Hi i try to check. Maybe i don’t understand . I see that i am in " Free" tier and usage is zero
Do I have to pay something even in free status?

Once you get your API key you do need to add some funds to make it usable. Probably just adding $5 is enough maybe. It detracts from your balance as you consume tokens thru the API.

1 Like

It’s also visible in →
Here you can see the following note “When your credit balance reaches $0, your API requests will stop working. Enable automatic recharge to automatically keep your credit balance topped up.”

First, please ensure that your API key has sufficient balance. If you are certain that your API key has enough balance, then you should check the usage page of your account, take a screenshot, and post it here. This way, others can help you identify if there are any issues you might have overlooked.

Thanks for help
The problem was that i had to enter some money to start using the api
Regards Doron

OpenAI should consider updating that error message text to suggest adding money to your account, because it trips everybody up, including me, which is how I knew what was wrong. It would save people a lot of time with a bit of a hint in the error text.

1 Like