Openai tools fine_tunes.prepare_data: permission denied?

Hi folks,

I’m trying to use the fine-tuning data prep tool but keep getting the error “permission denied:openai”.

  • I checked the path of where my openai module is installed
  • I then checked that I have write and read access to the path where the openai module is installed

Googled around but still couldn’t find the answer to this. Any help is appreciated!!

Welcome to the community @veronicaxge

It seems like incorrect shell syntax "!openai" instead of "openai" might be responsible. Read docs on fine-tuning before you continue.

Also this feature requires dependencies ( “pandas” ). To fix that run:

$ pip install openai[datalib]

Thank you! I tried doing that in the zsh shell without the exclamation mark as well, but still got the same error. I do have pandas installed already.

I just tried using it on my end on zsh after installing pandas and it worked without any errors.

Could be because of improperly installed module, incompatible version of dependencies on your system @veronicaxge

However the permission denied error seems odd. It would mean, the user does not have the necessary permissions to execute the “openai” command. To resolve this, you can try running the command with elevated privileges by using the “sudo” command.

Also, TBH I don’t use CLI tool for fine-tuning, instead I use the JS library.