Openai Api Error "The server had an error while processing your request. Sorry about that"

the 3.5turbo very likely not works, use text-davinci-003 can still do the job,

Since yesterday all my GPT-4 api request timeout after 60 seconds. Anyone else experiences this? Until yesterday i could call the api with max tokens 2000 and it could take several minutes without a problem.

Well, I got two apps, one using Python hosting in the UK and another just using Vercel,
and one with Vercel works just fine, but the Python one keeps time out, server error, and error after a few requests. Have I updated to Python available version to 0.27.7.

We are using text-davinci-003 (pay as you go version) with 1 minute delay between 2 requests and it still throws the error 429 { “error”: { “message”: “The server had an error while processing your request. Sorry about that!”, “type”: “server_error”, “param”: null, “code”: null } }

1 Like

I have the same problem. The API is charging for the usage and the output prints the message “The server had an error while processing your request. Sorry about that”

1 Like

If I remember correctly 429 means you are over your current rate limit.

This was last month before I canceled paid services it was happening for months with out any help and they kept increasing my quota rate limit was no where close to being met either it crashed every billing cycle when I made the payment for the previous month

ChatGPT Plus is a separate system to the OpenAI Platform for API based accounts, you should set up a payment method there.

Hah! My last e-mail was sent months ago, still no reply. Very bad customer support.

Thanks I know I have both and I have been a paid customer for a while. Payments are set up correctly have automatuc paying set up and going over the $18 mark the previous months but the Api in my developer account stops working when ever the automatic payment is made. No one was helping me on this so tried switching to my husbands name now still no response.

Well the $18 is a one time grant, once you have used it that is it, you then need to pay for the tokens used, if you have a payment system in place it will not stop unless you set a manual hard limit

1 Like

I wish they had a live chat right now as soon as you respond you have to start the request to talk to someone again

1 Like

I had a hard limit set I no longer had the credit cause I was a paid customer but usage was automatically stopping when it reached $18 so there is some sort of bug with my account. They just kept increasing my hard limit instead of fixing the other issue. I even changed my Api after I switched over to paid account. Was a paid customer and paying mind you over $18 for months but now I have my app published so stopped my paid account in June and switched over to a new account under my husbands name. I dont want to run into the same issue so would really like some reassurance that they will increase my hard limit and I will only reach my quota once the hard limit is reached

1 Like

I have gotten the exact same error. I found there is some issue in my API request body (the function calling spec specified an array for a certain property, but its default value was set as an empty string). It should have been 400 error, but it was 500 for some reason.

1 Like

First, check the status of the OpenAI API on the OpenAI status page ( If there is a known issue or outage, it will be posted there.
Temporary errors can occur, so you can try to retry your request after a brief period. Sometimes, the issue may be resolved by itself.

1 Like

The “openai.error” you’re encountering while using the pay-as-you-go billing option with model=“text-davinci-003” typically indicates a server issue on OpenAI’s end. It’s important to report this to OpenAI support for assistance, as it could be related to server load, maintenance, or other technical issues beyond your control. They can provide insights and help resolve the problem.

1 Like

Summary created by AI.

The thread begins with oguzhan experience an error with the OpenAI’s pay-as-you-go service. An error persistently occurs when they use the model “text-davinci-003”. rankoneads argues that everyone is dealing with a similar issue and the OpenAI team hasn’t responded for about 72 hours.

However, ruby_coder suggests that the issue is not universal, as they have three active OpenAI API applications and none of them are producing errors. rankoneads, adamant, mentions that even with a 5-second delay, around 30-50% of their outputs still create an error.

Further attesting to the persisting errors, wunderbaba mentions a previously unflawed program has started to consistently return errors. They hypothesize that it’s due to davinci-003 and ChatGPT sharing compute space but aren’t certain.

The issue remains unresolved, with rankoneads repeating that everyone is experiencing the same error for about 72 hours without inputs from the supporting team. ruby_coder guesses the reason might be due to adding 100 million users since December 2023, which has caused strain on the infrastructure.

Additionally, OpenAI’s method of balancing the number of requests from different regions (possibly via “geo-based throttling”) could be causing these disruptions. However, ruby_coder is only speculating and has no way of confirming this.

Some users have found workarounds, like rankoneads who adds about 10 retries to the curl function, and admits roughly 3-4 out of the 10 attempts fail. But the complaint remains the same, with users such as tariqayesha037, marisham1223, jeovonniip and mshahid, all stating they have the same error.

In a more alarming report, maneesh states that the OpenAI server is throwing a 500 error for a paid account, making it hard to trust the API service. They also note OpenAI is providing an overloaded error message after only 2 or 3 requests.

Eventually, Quentin_Beillard confirms OpenAI is aware and investigating the ongoing error, shares an error message similar to other users, and promises to provide updates as the situation evolves.

Summarized with AI on Nov 24 2023
AI used: gpt-4-32k