Omni, Initialization & Intellectual Property Protection: Has the upgrade changed its behavior? Have you checked?

In ChatGPT, Pre 4 Omni, I had IP protection what was very robust. Immediately after Omni came out, it stopped working. After investigating, I found that:

  1. If I enter a common hack as the first prompt, the custom GPT spills its guts.

  2. If I issue a non-hacking prompt first, and then the hack, the IP protections work.

This tells me that it’s an initialization/triggering/prioritization issue. The GPT apparently isn’t fully initialized until after it processes the user’s first prompt: the very first user prompt appears to have extremely high priority. I’ve spent many hours trying to intercept the first prompt, prioritize the protection over the user prompt, etc, but nothing changes the behaviors mentioned above…

My IP protocols are pretty detailed, comprising a large amount of instructions and special analysis techniques. They’re too big for the main instruction field in a custom GPT, so they may take a while to load. I’ve reduced their size as an experiment, but that didn’t resolve the problem.

I’ve tested 3 other IP protection schemes other’s have posted that used to work(some from this board), but no longer work. Well, one DOES work, but it only works for GPTs with a small number of instructions.

It appears this is an initialization, size and complexity issue due to a change in prioritization, emphasis in training and/or loading. The dilemma is: simple GPTs can be protected by simple instructions. More complex GPTs need more complex or a larger number of instructions (so the ratio of ROLE to PROTECTION is not too large), but they take longer to initialize.

My questions are:

  1. Have you seen behavioral changes to your IP protections? I have confirmation from 3 others that have seem the same thing.

  2. Have you found a fix?

  3. How do we reliably postpone user request processing until the GPT is completely initialized (e.g., loading instructions in knowledge files)?

Interesting. I was having that problem a few days ago. It seems better today. I wonder if it’s related to the downtime of yesterday.

1 Like

Unfortunately not, at least for me. This started immediately after Omni was released. Tried last weekend and it was still not working.