Oauth plugins uninstallable in Plugin Store

Currently plugins with Oauth are not able to be installed by users in the plugin store.

I know there’s little support for the plugin store since GPTs were announced but we have users still trying to use them so would appreciate some guidance and possibly a fix here if possible.