No SMS received during registration


I would like to create a new account for ChatGPT.
I have received a company-owned smartphone (iPhone).

For verification I entered the company phone number. However, I do not receive any SMS. At most I can press “Resend” a few times - but still no SMS arrives.

Then I tried to do it via my private phone number, unfortunately it doesn’t work either (my private ChatGPT, deleted account from previous employer with my phone number).
In consultation with IT, there is no blocking on the part of the mobile service provider (no number blocking).

What could be the reason that I do not receive SMS on my iPhone?

Thanks a lot!

If you didn’t get an error message about the type of phone number, then we can postulate other reasons:

  1. A temporary outage of the SMS gateway that OpenAI uses;
  2. An error in parsing or validating your phone number by the service that doesn’t return an error
  3. Carrier problem accepting SMS from origin country

With international numbers, one solution that helped some bypass a displayed error is to prefix “00” to the phone number that is input.

A phone number can only have two accounts associated. This however should produce an error upon attempted reuse.

Deleting an OpenAI account will make the associated phone number forever unusable to sign up again (until they change policy). We can’t use that failure as a diagnostic tool.