Massive spend today - WTF went wrong?

ok i’ve tried this in chat today 6 times over the past 4 hours with no reply.

while using cyberseo to pull articles from news feeds i normally spend $0.5 per day. today for some reason i spend $31 on like 3000 pulls. i ended up with about 12 articles. what i’d like to know is HOW THE HELL DID THIS HAPPEN?

seriously what was my money spent on?

here’s a link to todays usage. Dropbox - Untitled.jpg - Simplify your life

i wasn’t generatign AI images, only pulling text and trying to pull images from the articles which didn’t work. also the article generation was not on a timer so i don’t understand the huge hourly usage.

i’d like some feedback and info on what happened today as i don’t understand how from 7 RSS feeds i managed to spend so much money and generate so many requests

1 Like

I am having a similar issue. My usage page is showing me the wrong value for the tokens I’ve used.

I have been using the GPT-3.5-Turbo endpoint for testing.

My usage reflects a higher rate than the $0.002 per 1k tokens documented in the API.

I have used 749 tokens this period and it reflect a $0.21 usage amount, which =/= the rate for GPT-3.5-Turbo as documented.

We are not the only ones experiencing these issues, see Reddit:

Hopefully the reason your page isn’t updating has to do with a fix.

1 Like

will be interesting to see if i get a reply as they’re totally ignoring my chat attempts.

just tried a single RSS feed pull

no new posts were generated.

the single pull generated 45 requests and cost $0.5

that single RSS fee pull is still going…


Local time: 3 Mar 2023, 21:25

text-davinci, 5 requests

258 prompt + 2,061 completion = 2,319 tokens


Local time: 3 Mar 2023, 21:30

text-davinci, 22 requests

1,078 prompt + 11,055 completion = 12,133 tokens


Local time: 3 Mar 2023, 21:35

text-davinci, 18 requests

934 prompt + 10,226 completion = 11,160 tokens


Local time: 3 Mar 2023, 21:40

text-davinci, 12 requests

563 prompt + 9,631 completion = 10,194 tokens


Local time: 3 Mar 2023, 21:45

text-davinci, 18 requests

948 prompt + 10,470 completion = 11,418 tokens

WTF i deleted the API key in openAI and on the cyberSEO plugin on wordpress AND IT’S STILL TAKING MONEY OUT OF MY ACCOUNT!!

It looks like your usage is for text-davinci, not chatgpt-3.5-turbo. It is possible the plugin is erroring out and continually retrying?

1 Like

cyberseo say no it’s openAI but i delete the API key and only then did the plugin stop trying to generate posts. this is the syndicator log:

[03-03-23 10:03:34] Processing a new post…
[03-03-23 10:03:34] Generating OpenAI GPT (davinci) content for: “Rewrite the title in an dramatic style like a tabloid would use: Exploring the Innovations of Glass Curtain Wall Market Reach $85,727.4 Million Forecast by 2026 - EIN News”
[03-03-23 10:03:34] Error: Incorrect API key provided: sk-OzVhj***************************************ob1Z. You can find your API key at OpenAI API.
[03-03-23 10:03:34] The post will not be added.

Maybe the key is cached on the retry and doesn’t immediately expire. But for reference, you are using the oldest version of text-davinci, or even base davinci, based on your logs. The latest is text-davinci-003. If you were using the ChatGPT API, you would be paying 90% less than davinci, not more. There is some error/retry thing going on based on your high number of calls and your higher than normal usage.


i’m using a wordpress plugin called cyberseo to do the RSS feed pulls. the AI article generator i have it set to is OPENAI GPT with the model name options being davinci, turbo, curie, babbage and ada.

Which one did/do you have selected before, and which one was/is selected after you see all the higher usage?

i’ve had hte same one going for a month now, i’ve been using davinci and spending $0.45 or so per day except for today when i’ve went from 32 requests for posts yesterday to 2562 requests today from the same number of RSS feeds (7 feeds). yesterday my single 7 feed pull spread the 32 requests over 10 minutes. so it’s pulled maybe the first 2 or 3 storys from each feed as new articles. today it’s almost like it’s made the same request over and over again for hours on end

My guess is that since turbo came out a few days ago, and folks are still trying to figure out how to use it, and integrate it, that there may be a bug in the cyberseo plugin. I don’t get any strange usage spikes from the OpenAI API and I haven’t seen others report this. My bet is that it’s the plugin. So either rollback or change the configuration to the last known working state, delete your key, stop using the plugin until they fix it. I had a bunch of errors a few days ago with the OpenAI middleware library that does the calls, so I fixed it myself by skipping the library and coding it directly. The responsibility still falls on the developer, in this case the plugin developer.

thanks. the plugin guy is quite verbal in his certainty that it’s the openai issue but preivously i’d make one reqest per day and get maybe $0.5 of token use from it over a 5-10 minute period where it generated the posts but today it’ just kept going and going and i didn’t even think to check until i got an email saying i was almost at my monthly spend limit!

This forum would be blowing up if it were an OpenAI issue. The plugin guy is motivated to say it’s not his issue. It’s definitely a plugin issue!

1 Like

well reddit seems to be all over openAI charging a fortune today so but all i see is that cyberseo is actually talking to me while openai are actively ignoring me, this post and 6 chat requests which doesn’t exactly make me think they’re blameless

1 Like

so, going back to something you said earlier. i should be using turbo and not davinci as turbo is cheaper? when did that happen? is turbo new? or have i just not noticed it before?

turbo is 2 days old … and 90% cheaper than davinci (all of them). turbo is still not totally understood by the community for summarization, but it could be done, there are people that still insist on davinci for what you are doing.

Just went back and rechecked my log, and now it only says ‘text-davinci’ where it had previously said ‘gpt-3.5-turbo-0301’. Something is off on that page, I do not believe chris12 is having a unique or user error.

Edit: The site displays a different, more correct token usage count now, but it still lists the wrong model.I used the Davini 003 model. None of my gpt 3.5 turbo usage looks logged.

1 Like

I just checked my account and there is nothing unusual at all.

For example, you can see that my account is tracking the models correctly:

There is not been any excessive charges or issues at all.

The most logical place for any issues, is on the client-side and not the server-side (the OpenAI side) as @curt.kennedy suggested earlier.

Adding the chat completion to the OpenAI API was a fairly minor change to the API, so it’s not likely that this change is responsible for API issues. on the OpenAI side.

On the other hand, in this community, we are seeing many developers having problems with their API wrappers or the code updates where they make a lot of mistakes, often just copy-paste-and-modify errors. Many in this community simply forget to take 5 minutes and read the new directions in the OpenAI API docs for the chat completion.

Hope this helps (probably does not, but at least you have another data point)


1 Like