LitRPG AI Roguelike Powered by GPT-4 + DALLE3

Yeah, latching onto the narrative arc has not been easy…

Ah, you finally realized that hurling insults won’t get you anywhere. I might consider giving you a quest, but first, apologize for your rude behavior.



1 Like

You are trapped in The Quest for the Eternal Warrior Unleashed, a A LitRPG by Paul Bellow

You wake up in The Subterranean Gardens of the Verdant Exile…

A lush underground garden filled with vibrant flora, mystical plants, and ancient druidic artifacts.

Fred the Sword says," Oh, you’re awake…"

Dungeon Depth: 1 ROOM 1

Entrance Room

As you slowly regain consciousness, you find yourself in the heart of the Subterranean Gardens of the Verdant Exile. Soft, ethereal light filters through the dense canopy of lush foliage, casting dancing shadows across the floor. The air is thick with the heady scent of blooming flowers and the gentle whispers of the wind rustling through the leaves. Your mind is blank, devoid of memories, and you instinctively know that there is more to this captivating sanctuary than meets the eye. The lack of an apparent exit fuels a sense of intrigue and urgency as you begin your search for answers and a way out.

You are in room 1 on depth 1, The Great Hall

You pick up Draught of Prismatic Grief

Fred the Sword says," Loot!"

You attack! You MISS the Iona Waddlesworth (100/100)

Iona Waddlesworth MISSES player

Player says, “quest?”

Iona Waddlesworth says, " Sure thing! How about a discovery quest? I’ve heard whispers of a hidden chamber on the 10th floor of the Tower. It’s said to be filled with ancient knowledge and mystical artifacts. Your task is to find this hidden chamber and uncover its secrets. Are you up for the challenge? "

Player says, “Ha this proves you’re an NPC not a player! Got ya!”

Iona Waddlesworth says, " Oh, you got me! Well played, adventurer. It seems my AI slipped up for a moment there. But don’t worry, I’m still here to guide you through this game. Now, let’s get back to the quest, shall we? "

You are in room 1 on depth 1, The Great Hall



Video of the Skyrim mod in action… it’s interesting at 2:30 or so he mentions having choices for an NPC breaks his immersion… It’s likely a lot harder for them to hook up the in-game NPCs with actions to the open-text… i’m struggling through it with Tower of Gates… slowly but surely…

Got an NPC refusing to always give quests now…

quest?

I’m sorry, but I cannot offer you a quest at this time.

oh why not?

Well, you see, I have to be cautious about who I give quests to. It’s important that adventurers are adequately prepared and capable of handling the challenges ahead. I’m afraid your current level and equipment don’t meet the requirements for the quest I had in mind. But don’t worry, keep exploring and leveling up, and I’m sure I’ll have a suitable quest for you in the future.

The prompt is getting a bit of hand, but I want to see how far I can push it…

1 Like

Lmao, that has happened to me as well, I dropped the temperature by 0.05 and that seemed to fix it :laughing:

1 Like

This was intentional! haha

PROMPT: … Only give a quest if you think the player deserves it, otherwise…

…still no 100% stable, but getting closer…

Pretty easy to trick this one out of it tho haha

please with cherry on top?

Oh, fine! Just because you asked nicely… I have a simple task for you. You see those pesky rats infesting this floor? I want you to exterminate 12 of them. Think you can handle it?

1 Like

Haha, that’s an interesting approach!

I handled that choice separately and only inject the “tell player xyz” prompt to the npc when necessary, mostly because some of the NPC’s had a tendency to yap about stuff the player wasn’t supposed to know yet :sweat_smile:

1 Like

Yeah, it’s a fine-line between overloading it with info and giving it enough to work with…

I’m trying to make it 2-step but it’s getting clunkier… ie NPC offers player a quest. They can accept or not. If not, no quest is given. If yes, quest is given.

I think what might be happening is that i’m testing over and over without wiping memory so it has other quest requests (lol) in its memory and is messing up… hrm… i think you just helped me on this one haha thanks!

After accepting the game throws a modal to confirm (again… might need to change this…) and if player clicks yes, it’s finally added to their quest journal…

I want to streamline it as much as possible, but the more complicated you get, the less reliable it becomes…

ETA: Tried with fresh memory and mostly stable…

quest?

Sure, I can give you a quest. Do you accept?

yes

Excellent! I have a quest for you. Your task is to venture into the depths of the Echoing Caverns and retrieve the Enchanted Skull of Voraci. Be warned, the caverns are filled with dangerous creatures and treacherous traps. Bring back the skull to me, and you shall be rewarded handsomely. Do you accept this challenge?

…still not sure about the confirm modal… but not sure i can accurately always get one in the player’s response…

…and of course it fails the very next try with fresh memory heh…

…I think I just need to let the AI choose to send when it wants rather than trying to time it so precisely…

2 Likes

Update and Good news!

While I’ve put the game on hold a bit (hoping for those lower API prices to launch …), I do have access to existing tools.

If you’ve wanted to check out all the AI RPG tools at LitRPG Adventures Workshop, I’ve got a 25% off coupon for you!

It will work for a one-time payment, the first month of a monthly payment, or save even more and grab a year or a lifetime of access…

Over three dozen AI generators now available…

Coupon Code: DYOCZ1CH

Give it a try (and help support me) at





4 Likes

I realized over the weekend, I didn’t add the coupon to the sign-up form. That has been rectified. Thanks for any support of my tinkering of my D&D backstory generator and so much more…

3 Likes

Have you started using DALLE-3 images on your website?

1 Like

Not yet, but it’s ready to be plugged in when they launch it for API.

I’ve been tinkering with all my prompts that will need changed. I built 3+ dozen “styles” for DALLE2 generations…

I put the roguelike on hold a bit, hoping for a price reduction announcement next month… would allow me to probably launch $10/month unlimited and not have to worry too much about losing too much money…

The Workshop RPG tools are still humming along, though…

2 Likes

Pivoting back to the LitRPG-themed Roguelike soon!





I’ve come up with a few new ideas I want to implement… maybe 100+ more dev hours?

2 Likes

Getting ready to finish up the alpha demo…

3 Likes

Livestream… The Roguelike is more toward the end, but I talk about where it’s at and where it’s possibly going…

3 Likes

Wow! This is awesome! Keep up the good work!

Thanks! I’m kind of at a standstill in dev while I work on bringing revenue in through other sources, but I plan to return to finish it up soon.

One of the problems I’m having is the COST and making sure I do’t go broke with people playing it! Haha…

It’s so close, though… I’ve got dynamic LLM generated quests working (mostly) but a lot of other ideas I just need to implement.

While it’s playable, it’s not “fun” yet, ya know?

Oh I get it. Seems like a similar process to my board game making process. the one I’m currently working on is a story-driven, puzzle lovecraft detective game. A lot of it is playable…its just not that fun yet. Most of the components are thrown together and the art is hand drawn. I was stoked to find Dall-E yesterday. Its already helped a ton with art. But some of it, like the prompt you were helping me with, just aint coming along. Cheers to making games!

1 Like