Issue with Hyperlink Formatting - Persistent bug on both Firefox and Safari

I’ve encountered a persistent issue with the hyperlink formatting in the chat responses generated by the OpenAI API, specifically in the text-based interface. The links are initially formatted as HTML but then revert to plain text, styled in blue, and are not clickable. This issue occurs consistently across multiple browsers, including Firefox (version 121.0.1) and Safari (version 16.6).

Steps to Reproduce:

  1. Request the AI to provide a hyperlink in the chat.
  2. Observe the AI’s response, where the hyperlink is written out in HTML link format.
  3. After the response is generated, the hyperlink text turns into the title text, becomes blue, implying a link, but it is not clickable.

Expected Behavior: The hyperlinks provided in the AI’s response should be clickable and direct me to the respective URLs.

Actual Behavior: The hyperlinks are not clickable and do not function as intended.

Environment:

  • Operating System: macOS 13.6.3 (22G436)
  • Browsers Tested: Firefox 121.0.1 (64-bit), Safari Version 16.6 (18615.3.12.11.2)

This issue has been impacting the usability of the service, as it would require inspecting the link in the browser, copying from the html, and then accessing the resources mentioned by the AI. Clearly this is not workable for average users. Any assistance in resolving this would be greatly appreciated.

Thank you for your attention to this matter.

Best,
Satoshi 中本哲史
satoshi@donatebymail.org

Update: the links work just fine in the iOS app, it appears to be a browser issue specifically