Issue with Checking Credit Balance for Open API

I’ve been trying to add money to my balance, but there’s this strange issue I have where the credit balance keeps continuously loading for long periods of time—I can’t use my card to add money to it either, but the error seems to be on OpenAI’s end. I tried to wait it out, but I only got the error message, saying “We experienced an error while checking your credit balance, please try again later. If this issue persists, contact us through our help center.”

I’ve tried contacting support about this several times, but I only got automated messages in return, one even ignoring the updates I’ve sent altogether. I can’t find any post that has anything similar to my current situation either, so I was wondering if anybody has a similar issue to mine? I would appreciate my insight or possible solution on how to solve this irritating issue.

Welcome to the forum!

First off the only ones who can really help you can only be reached by contacting support as you noted. We can only give some other ideas with no guarantees.

Have you tried using a different credit card?

I’m having the same issue and it’s most definitely not the card. The balance will not load at all, and it constantly shows an error.

Unfortunately, I only have a single card. But I don’t think the issue is on the card or bank’s end.

i’m having the same issue as well. [quote=“nicetea, post:1, topic:573340, full:true”]
I’ve been trying to add money to my balance, but there’s this strange issue I have where the credit balance keeps continuously loading for long periods of time—I can’t use my card to add money to it either, but the error seems to be on OpenAI’s end. I tried to wait it out, but I only got the error message, saying “We experienced an error while checking your credit balance, please try again later. If this issue persists, contact us through our help center.”

I’ve tried contacting support about this several times, but I only got automated messages in return, one even ignoring the updates I’ve sent altogether. I can’t find any post that has anything similar to my current situation either, so I was wondering if anybody has a similar issue to mine? I would appreciate my insight or possible solution on how to solve this irritating issue.
[/quote]

If I see two more users report this same issue in the next few hours I will pin the topic which will usually get more users to post if they have the issue. Also pinned topics tend to get noticed by OpenAI Staff.

I have to be cautious with pinning topics and don’t want to turn them into the boy who cried wolf.

Still no luck or improvement on the issue I’m having but I think it’s best to share more info on my situation, this issue has been going for a day or two. I also tried clearing cookies and cache to no avail, switching to a different browser also didn’t work either.

This is just a really really long shot and only suggesting because you are out of ideas.

The CAPTCHA problem is being noted everywhere and then one user just noted that resynching their clock fixed the problem.

I resynced the clock and it didn’t do anything, I believe the CAPTCHA problem you’re referring to is for ChatGPT, my issue is for the credit balance in the Billing Settings for the API.

That was understood when I posted the suggestion which is why it started with

This is just a really really long shot and only suggesting because you are out of ideas.

1 Like

They keep over charging mine, put me in minus £16 each time on the pay as you go option. Reported it and was given a ‘tough luck’ message really.

I am Also having this problem with my Credit balance not loading

Same her. Notice a CORS error on endpoint

               https://api.openai.com/dashboard/billing/credit_grants