InvalidRequestError: The model: `gpt-4` does not exist despite getting invite

I got the email that I got gpt-4 access, but I tried using it on my code with:

chat = ChatOpenAI(temperature=0, model = "gpt-4")

but I get the error that:

****InvalidRequestError: The model: gpt-4 does not exist

After reading some topics on this forum months ago, they said that making a new API key will give you gpt-4 access. I tried doing that, and using the new key, but I still get the same issue:

****InvalidRequestError: The model: gpt-4 does not exist

What is the issue?

When I got mine, back in March, after the second day of non stop working on the evals repository, I went to sleep - as I was super tired. When I tested it on the next day it was working. I didn’t test it right when I got it, so I didn’t get to experience the same as you.

Are other models working for you? If so, Id suggest reaching out to support, I’ve seen billing errors taking a few business day to get solved on this route

Yes. GPT 3.5 turbo and GPT 3,5 turbo 16k work no problem for me. However, I cannot access gpt-4 models despite getting off the waitlist. There might be possio

The proper model name is gpt-4-0613 not gpt-4.

To list available models use:

I tried that as well, and I get the same error:

InvalidRequestError: The model: gpt-4-0613 does not exist


chat = ChatOpenAI(temperature=0, model = "gpt-4-0613")

hey, check this update out, if you think you still have something wrong, checkout support - I’m afraid those are the routes you can take to understand or solve this

This should be resolved now! Please get in touch with us if it continues to be an issue.

1 Like