Installing the retrieval plugin

While installing the retrieval plugin from GitHub - openai/chatgpt-retrieval-plugin

I am getting the below error. Did anyone face this?

• Installing mmh3 (3.0.0): Failed


Backend subprocess exited when trying to invoke build_wheel

running bdist_wheel
running build
running build_ext
building ‘mmh3’ extension
creating build
creating build/temp.macosx-10.9-universal2-cpython-310
clang -Wno-unused-result -Wsign-compare -Wunreachable-code -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -arch arm64 -arch x86_64 -g -I/private/var/folders/j2/xhp0nhgn4vb7mjtpjc4pcrvm0000gp/T/tmpltie8o8m/.venv/include -I/Library/Frameworks/Python.framework/Versions/3.10/include/python3.10 -c MurmurHash3.cpp -o build/temp.macosx-10.9-universal2-cpython-310/MurmurHash3.o
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
error: command ‘/usr/bin/clang’ failed with exit code 1

at ~/opt/anaconda3/lib/python3.9/site-packages/poetry/installation/ in _prepare
149│ error = ChefBuildError(“\n\n”.join(message_parts))
151│ if error is not None:
→ 152│ raise error from None
154│ return path
156│ def _prepare_sdist(self, archive: Path, destination: Path | None = None) → Path:

Note: This error originates from the build backend, and is likely not a problem with poetry but with mmh3 (3.0.0) not supporting PEP 517 builds. You can verify this by running ‘pip wheel --use-pep517 “mmh3 (==3.0.0)”’.

You just need to update the xcode Command Line Tools via xcode-select --install

Source: xcode - Why am I getting an “invalid active developer path” when attempting to use Git after upgrading to macOS Ventura? - Ask Different

1 Like

I’v met same problem… it seems to be:
error: Microsoft Visual C++ 14.0 or greater is required. Get it with “Microsoft C++ Build Tools”: Microsoft C++ Build Tools - Visual Studio

after installing this, this problem fixed.

My problem solved with what vjaros1 suggested

I am facing the same issue on a linux machine. Any solution for this?

Hi, @dedejski44

This one worked for me:

sudo apt-get install python3.10-dev

And then again:

poetry install

This does not work for me. On Ubuntu for WSL. installed python3.10-dev. Still an error with mmh3 (3.0.0) not supporting PEP 517 builds.

I seem to be able to pip install mmh3 (3.1.0) → can that version somehow be used?

UPDATE: the following command FINALLY worked for me. Not sure which package was the needed one:
sudo apt-get install make automake gcc g++