Images not saving on new ChatGPT Mac App

I have just installed the new Mac App and it is great that it integrates so well. When I ask it to generate a picture, I want to save the image but if you right click on the image, there is no save as option. There is a copy but it just copies text for the sandbox that you cannot access.

I tried asking the AI to give me a download link. Most of the times it failed to find or open the file. Occasionally it said I will try a different way but regenerated a different image rather than helping download the one I already had.

Is there a way to download the images? Could the app be enhanced to automatically save generated images into a folder in the Pictures folder etc.

1 Like

Double-click the image and then open it in Preview. From there you can export it as a jpg (or something else).

Thank you for the reply. Double clicking does nothing on my mac. I am using an M2 Macbook Air.

What version of the app are you using?

I have the same problem, the Mac OS ChatGPT App does not allow downloading photos. I’m on Version 1.2024.138 (1716432765), and I have a Macbook Pro (M1 Pro).

Same exact problem here. Double click does not work. 2023 M2 Mac Studio, OS Sonoma 14.2. Left click opens a ghostly window that says “nothing selected”, no option to do anything with it. Clicking on images, right clicking on images etc, no joy.

1 Like

I have the same experience. I can generate images but cannot click on them. You can tell the AI to create a download link to the files and it will give you one. Sometimes this link is also bugged but work most of the time. Another problem when the AI generates multiple pictures all of the download links contains the same picture and the AI cannot solve this problem. I hope a quick fix will come soon.

does double clicking on the image work, and then in the right top corner click ‘open in preview’ and from there you can go to file/export as jpeg

Double clicking on the image worked once for me and then stopped working.
Sometimes, double clicking opens a window but says nothing selected. Most times, double clicking on the image gets no response. M1 mac.

Same problem, and latest version. Single click does nothing at all. Double click once opened a preview but the preview pane was blank saying it couldn’t find the image. Further double clicks then do nothing.

win10 same same - i can’t download any of the created files

Easy Solution, Guys just ask for the Links of the the Pictures

You Can all the ask in the first Place in the prompt to provide links to the generated images … directly… so you don’t need another promt for asking

Download link is not working correctly all the time. Just read my comment…

I tried doing this, then it gave me links that did not work. After trying a number of different ways, I managed to get it to give me a download link that worked. I then asked it to remember how it did that and always use that method. It then proceeded to give me broken links again!

I find this to be the very typical “cheeky” behavior that occurs precisely when you ask in more detail and insistently. I feel that the less pressure applied, the more willingly ChatGPT provides support and makes fewer “careless mistakes”, as if it gets nervous or is under stress…
you can ask to validate the links before printing, and double check and if there is any problem to recreate and check again before printing the link

double-clicking did not work for me either - but asking for a link (and asking to validate) was successful - thanks!

1 Like

Well it works like this from the beginning…