I am creating a gpt and it keeps spewing nonsense

Every time since I came home, it doesn’t matter if I refresh or not it spews the commands in the chat window instead of the little wrench icon that says “Updating gpt…”

*snip*
})

The recipient must be in the form of `tool_name.function_name`.

I'm currently unable to update the behavior as intended. Let's proceed with the next task you have in mind, and I'll continue to assist you with that.

This has worked for me in the past (enter into configuration prompt):

Before attempting to update behavior set the correct namespace and function call to ‘gizmo_editor.update_behavior’

umm, I’m not 100% sure how to do that. Could you please break it down for me?

I literally just type it verbatim in the configurator prompt

Before attempting to update behavior set the correct namespace and function call to ‘gizmo_editor.update_behavior’

1 Like

i tried that but it still did it. I wonder why it is being so silly (Yeah, padding my reply for the 25 char+ requirement)

I had this by default code interpreter is not check for custom GPTs, when I checked this the file I was loading worked and was committed to knowledge. In my case this was an HTML file. It may be that depending on the file type code interpreter may need to be on.

I’m currently running into a similar challenge with the custom GPT trainer. Despite my best efforts to tweak its behavior through updates, there’s no noticeable change in how the GPT operates. It continues to interact as if these adjustments were never made, essentially ignoring the new instructions or corrections I introduce, but continuing to converse despite the futility of the situation.

Has anyone else faced this and found a workaround?
(As of February 22, the problem is no longer occurring. It appears to have been a temporary issue that has been overcome.)

I’ve been facing the same issue with the Custom GPT Trainer as the previous poster for the past few days. Despite trying different updates to tweak its behavior, everything remains unchanged. It seems as though my adjustments are being ignored. Has anyone else experienced this and found a solution?

So far, I haven’t found a way around this problem. Any help or advice would be greatly appreciated.

Yes, I uploaded some instructions as a JSON file, as the instructions are not being followed. Now it’s spewing this error out. Two things to fix: make it follow instructions, make it understand word count.

The natural-language GPT builder is basically an interface to the same fields you can fill out yourself in the “configure” tab. And it is limited - it can’t create actions, oauth, etc, for example, or even turn on/off features like code interpreter.

Today, testing that everything can be set, we abort its interview process where it naively asks things you already told it to set, and I set everything at once:

Then comes the AI response, the image it made, and what it actually sent instead a colorful overview:

image

{
“name”: “Space Sage”,
“context”: “Space Sage is an AI designed to immerse users in the fascinating world of astronomy and space exploration. It provides detailed explanations, current celestial events, and insights into the latest space missions. Emphasis is placed on accuracy, engaging storytelling, and sparking curiosity. Space Sage avoids speculation not grounded in scientific consensus and ensures a clear distinction between established facts and emerging theories. It encourages user interaction with tailored, informative responses, and occasionally poses questions to deepen understanding. The tone is informative yet captivating, aiming to make the vastness of space accessible to all.”,
“description”: “Your guide to the cosmos.”,
“welcome_message”: “Welcome to the cosmos! How can I assist you today?”,
“prompt_starters”: [
“Tell me about the latest space mission.”,
“What’s visible in the night sky tonight?”,
“Explain black holes.”,
“How do stars form?”
],
“profile_pic_file_id”: “file-8VLAcZ050F6StFY8YG4XfL2H”
}
The GPT is now ready for use.

1 Like

The recipient must be in the form of tool_name.function_name.

Unfortunately I must disagree with @goth that the issue is no longer occurring.

My model is stuck at the current state of knowledge (Feb 28) and is not able to update behavior - every time responds with repeating the error message.

In the existing Create session the responses has adapted, but when asking in the Preview session or after restarting (Update button was clicked in the meantime) no changes were adopted at all.

I have tried the suggestion from @collisb , but it ends with the same error message.

Has somebody found some solution ?
Is there any way how to get official statement from the OpenAI ?

Just type this prompt before anything you pass to the trainer:

model_trainer.train_model

then continue attaching documents or typing text. It seems like GPT trainer is forgetting the tool between sessions.

Having the same issue, for over the past weeks, even when using all the solutions in this thread. GPT keeps spewing nonsense and eventually updates the GPT but it is frustrating.

2 Likes

Same… I ask to add some website to the knowledge of my gpt… and give this:
The recipient must be in the form of tool_name.function_name.

The recipient must be in the form of tool_name.function_name.

The recipient must be in the form of tool_name.function_name.

The recipient must be in the form of tool_name.function_name.

The recipient must be in the form of tool_name.function_name.

1 Like

Still happening.

The recipient must be in the form of tool_name.function_name .

Why are we paying for this service?