"GPT" assistants with API I built not working on mobile app. Can I enable it somehow?

I created a new ChatGPT “GPT” that works fine on PC but got this error in the mobile app “This GPT is not yet available on Android” and the same for “IOS” when trying on Ipad.

Why is that and can I enable the GPT to work on mobile? In the mobile apps I can use other GPTs that I have created just fine.

The difference is that this GPT uses an API to connect to a database. Could that be the reason? Can I do something about it?

1 Like

I have the same issue, let me know if there is an answer.

I have the same issue on mobile devices with my GPTs that use an API

According to the power user Nick Dobos the reason is legal, that Apple and Google will not allow API calling in apps in this way due to how the law is written.

twitter post link: NickADobos/status/1724178638839677252

If so, we can’t expect this to be solved any time soon.

As of right now it looks like the only way around this is to verify you own the domain by going into profile > settings and beta > builder profile > adding your domain > builder profile > adding the website (below your name) > click the drop down arrow from the domain you added > verify > copy code > heading to your domain DNS > Add a TXT into your DNS records and paste the OpenAI verification code there.

Says it can take up to 48 hours but it only took about 15 min.

Hope this helps!

1 Like

Another workaround, in case you just want ChatGPT to talk to an API from mobile app without needing the additional capabilities, is signing up as a plugin developer and making a custom plugin. This way, as long as you start the conversation on the browser, you can continue it w/API access from the mobile app.

They are working now by the way!

1 Like