Got access to GPT4 API two weeks back but says "model does not exist"

I had gotten GPT4 API access two week back. Been trying to get it but no use. Can please someone help. I have one very critical workflows dependent on this.

1 Like

Welcome @jot1

When you say you don’t have access to the model via API, do you mean it’s not showing in response to list models endpoint request ? Or that you’re getting an error while making a request?

If it’s the latter, please share the code you are using to call the API.


models endpoint is not showing “gpt-4” in the response.

I have also tried putting the OpenAI OrgID in the headers as listed in the other thread. The email ID from which I requested the API request is the same as the one I have logged in here in the forum.

Can you please help.

Please share the complete response of the list model request in markdown and the endpoint which you want to call the model at.

LMK if you can access the model on Playground in chat mode


No I do not have access in Playground chat mode. I can also share the Org ID if you want. Would be super great if you could help here.

This is the list of models returned by models endpoint

"id": "babbage",
"id": "davinci",
"id": "text-davinci-edit-001",
"id": "babbage-code-search-code",
"id": "text-similarity-babbage-001",
"id": "gpt-3.5-turbo",
"id": "code-davinci-edit-001",
"id": "text-davinci-001",
"id": "ada",
"id": "babbage-code-search-text",
"id": "babbage-similarity",
"id": "gpt-3.5-turbo-0301",
"id": "code-search-babbage-text-001",
"id": "text-curie-001",
"id": "whisper-1",
"id": "code-search-babbage-code-001",
"id": "text-davinci-003",
"id": "text-ada-001",
"id": "text-embedding-ada-002",
"id": "text-similarity-ada-001",
"id": "curie-instruct-beta",
"id": "ada-code-search-code",
"id": "ada-similarity",
"id": "code-search-ada-text-001",
"id": "text-search-ada-query-001",
"id": "davinci-search-document",
"id": "ada-code-search-text",
"id": "text-search-ada-doc-001",
"id": "davinci-instruct-beta",
"id": "text-similarity-curie-001",
"id": "code-search-ada-code-001",
"id": "ada-search-query",
"id": "text-search-davinci-query-001",
"id": "curie-search-query",
"id": "davinci-search-query",
"id": "babbage-search-document",
"id": "ada-search-document",
"id": "text-search-curie-query-001",
"id": "text-search-babbage-doc-001",
"id": "curie-search-document",
"id": "text-search-curie-doc-001",
"id": "babbage-search-query",
"id": "text-babbage-001",
"id": "text-search-davinci-doc-001",
"id": "text-search-babbage-query-001",
"id": "curie-similarity",
"id": "curie",
"id": "text-similarity-davinci-001",
"id": "text-davinci-002",
"id": "davinci-similarity",
"id": "cushman:2020-05-03",
"id": "ada:2020-05-03",
"id": "babbage:2020-05-03",
"id": "curie:2020-05-03",
"id": "davinci:2020-05-03",
"id": "if-davinci-v2",
"id": "if-curie-v2",
"id": "if-davinci:3.0.0",
"id": "davinci-if:3.0.0",
"id": "davinci-instruct-beta:2.0.0",
"id": "text-ada:001",
"id": "text-davinci:001",
"id": "text-curie:001",
"id": "text-babbage:001",

Any updates here? We have also filed a PR for OpenAI Eval. Link - Emergency department classification eval by abhinayvyas · Pull Request #587 · openai/evals · GitHub

One workflow is in critical state due to this requirement. Can you please help.

Org ID - org-5d6Wje7Qw2CviZoAKbiaOZTT

Attaching the invite for you reference. I got the access sometime back but not able to access it either in Playground or API. Please help

If you’re part of multiple orgs (personal + Work_org) use the org id using which you applied for access and switch to the org using dropdown on the top right while using playground.

I had a account from my personal email. And one account from my work email. I had applied from the work email and gotten access to it and I am using that account only. Still not able to use the API.

Please help here. I am share whatever detail you want from my end. thanks

TBF, I can try to help with what I knew, but in the end I’m not OpenAI employee I would recommend contacting them via

Try logging into the account with access to gpt-4 in a new browser or in incognito mode.

Exactly the same issue - got access to the model (at least in email notification) bot in reality model is not available

1 Like

@logankilpatrick can you please help here. I was super stoked that I got access to the GPT 4 API but now extremely disappointed. I have also submitted OpenAI Eval for this. Also a payer for ChatGPTPlus since day one. I am building a product in medical and would love to use GPT4 in our product.

Are you using v1/chat/completions endpoint?

Yes I am using that only


If click on the link below - which models can you see?

For those with no access to GPT-4: there are gpt-3.5-turbo-*** only, but it is fully accessible, even for free accounts.

If you can access that playground - and you can’t see any model of gpt-4, you can confirm it is something with your account/invitation - it is happening with a few others in this forum;

Or maybe you can see some specific gpt-4-**** model(s) related to your account with different name suffixes.

Some say: “you can specify your organization in your API requests with the header”: OpenAI-Organization

For others, the correct words are:
“you must specify your organization…” in that header.

I only see GPT 3.5* as shown below. And I have tried sending in OpenAI Organization ID in the header and that also does not work.

Someone from OpenAI please help me here

Thanks for the reply. This playground is for GPT-4 models only - and these two 3.5 are for demo - nothing else. So it is confirmed - the problem is with your account - they invited you but didn’t grant access yet. You are on the right path, if you have GPT-4 paid account I supposed you received Tier2 support contact - try them again. Tier1 Help Bot in is useless, IMHO.

A quick update. My personal and professional accounts are now merged. The personal account show GPT4 in the playground. The professional account (rapidclaims) does not.

But I am still not able to call the GPT-4 API. Personal account’s API Key does allow sending in OpenAI’s Org ID. Professional account’s API Key says that the model does not exist.


Access is granted to Org ID. Every account initially gets its own org id.

You cannot “merge” accounts, only add them to an org. To access GPT-4 on an your other account that doesn’t have it, you’ll have to add this account to the org of the account that has access.

thanks @sps Super super helpful. API access works

1 Like