Google SSO not working for many

While I’ve spoke to some users who can log in with Google SSO, I’ve also spoken with many others who have the same problem as I.

We can’t login to our accounts with the Google SSO. It puts us in the sign in loop where it continues to ask us to login. Like others. Ive tried clearing the cache, using other browsers, using other devices. I’ve tried creating a new password with opening so I can use a traditional sign in, only to get an error stating “this is not your original authentication method.” This has been going on for me since yesterday (2/27) morning.

If you’re having a similar problem comment here so we can learn from each other and hopefully bring some attention to the matter.

1 Like

I’ve been able to create an entirely new account using a traditional username/password. This method signs in just fine from the same computer and browser.

But I still can’t sign in with my Google account where all of my good data is. T_T


This seems to be an ongoing problem? Same thing here on numerous different browsers.

Why offer Google SSO to your service if you can’t even keep it working?