Fine Tunes not Listed When Using the API

I have five fine tunes listed:

image

When I try to list them or delete one of them through the API, none are returned:

{
    "object": "list",
    "data": [],
    "next_starting_after": null
}

The API call I’m using in Postman to list them is

curl --location 'https://api.openai.com/v1/fine-tunes' \

--header 'Authorization: Bearer REDACTED'

What am I doing wrong please?

\Hi and welcome to the Developer Forum!

Those seem to be log entries, for attempts at fine-tune creation, if you note the status of “failed” meaning that they do not actually exist, that is just a log of attempts and their current status.

You need to start a fine tuning job that succeeds in order for there to be a fine-tune model to list.

Hope this helps.

Hi @Foxalabs, and thanks for the welcome.

Three did succeed and you can see their times on the right, i just removed their names from the screenshot.

well the command from the docs is

curl https://api.openai.com/v1/models \
  -H "Authorization: Bearer $OPENAI_API_KEY"

worth trying that exactly as is, take from

Thanks for the suggestion; I just tried that in Postman and unfortunately I’m still not getting anything back.

At this point, unless someone else can spot a simple error I’ve missed, I’d reach out to help.openai.com and use the support bot in the bottom right corner.

2 Likes