"Error saving draft" when creating an authenticated action in a GPT

That didn’t help. Even using VPN.

1 Like

Same issue here :axe: :axe: ! hopefully it will be fixed soon

Same issue, commenting to follow the resolution.

Same issue here :disappointed:! Go to Reply :hammer_and_wrench::hammer_and_wrench:

I’m also facing the same issue. I noticed I was able to save the Bearer token when I connected to another Wi-Fi, so it could really be related to the network. I wonder if this has something to do with DDoS prevention, somehow.

I have successfully resolved this issue. Try to follow these steps:

  1. Copy your OPENAPI schema
  2. Delete the Action
  3. Save the GPT
  4. Create new empty action (do not fill the schema)
  5. Add new API token
  6. Save the Action
  7. Fill the schema
  8. Save the Action again

Tada :tada:

1 Like

I tried with your steps, but keep getting the error :smiling_face_with_tear:
I’ll keep trying with different steps combinations.

Token was successfully saved but then the action didn’t work. I wasn’t able to make it working. I deleted the GPT and then I wasn’t able to replicate these steps with saving the token.

Sorry for unfulfilled expectations

We are having the same issue.

Commenting here so we can track the issue.

Try to switch to mobile internet (do not use wifi internet connection). It’s currently working again for me. I have deleted the action from mobile internet connection and reproduced the steps mentioned above and it works again…

Using mobile internet (hotspot) actually worked for me, first try! Finally able to proceed with further testing - looks good for communication with my API so far.

Thanks for the tip!

I am using a desktop with ethernet connection, so no option to do about that. However is curious and weird this relation with the network.
Still wait for a fix


Entering the discussion with hopes of hearing a solution. I personally think there is nothing that can be done by users. This is probably just a Beta larger scale issue.

This should be high prio. Being unable to secure the service is untenable.

1 Like

agreed, still unable to save with the API key as of now

Same here as well, it’s really frustrating, been on that for 2 days
I hope the dev responsible of that to fix this issue in the upcoming week

FYI, tried changing network, changing browser (Chrome, Safari, Firefox), deleting action then recreating… all non logical combinations mentioned here

Same problme here :frowning: not able to add any kind of authentication

Same thing, severa, days later and still waiting for a solution.

The problem seems to be linked to the IP address being used. I attempted various solutions, including modifying actions, re-creating the GPT, and switching browsers and devices, but continued to encounter “Error saving draft” and “Internal Server Error” in the dev console.
Eventually, I resolved the issue by:

1. Connecting via a VPN, specifically Mullvad, with the location set to Poland.
2. Clearing the browser cache and refreshing the GPT editing page.
3. Recreating the action.
4. Setting up bearer token authentication.

This allowed me to successfully save the draft. Other users have found success by connecting through their mobile network, indicating that the issue is indeed IP address related. If using a different VPN, try changing servers until you find one that allows you to save the draft.

1 Like

Has that fixed the issue on your ordinary IP as well?