Error "Incorrect API key provided" when using DALL·E on the website

When using DALL·E on the website (i.e. not the API) and submitting a phrase, it says:

Incorrect API key provided: sess-PZt*****l1hj. You can find your API key at

Maybe I’ve accidentally deleted the API key in the past, but I now find no way to enter another API key in the DALL·E website.

Can someone please help me to use DALL·E through the website (i.e. not the API) again?


Welcome to the community.

It’s working here.

You might try reloading the browser screen.

Good luck!


I’ve now logged off and on again, and now it seems to work again.

1 Like

I am having the same issue, logging in and refreshing have not worked


Maybe it also can occur when the servers are under too much load because of too many concurrent users?

1 Like

Same issue here.
Logged in via Google and on the trial plan.
Didn’t have an API key generated at first, but generating one didn’t solve anything.
Tried logout and log in + refreshing with cache clearing before and after key generation. Nothing worked.

  • Reset cookies
  • Reloading your browser
  • The user is your OpenAI email and the password should be generated in the user area on the OpenAI website (OpenAI API)

Hi all,
I am a brand new user and the first experience with OpenAI / Dall E2 was an error. I thought it was my lack of knowledge. “Happy” to see I am not the only one.

When I used the Dall E2 site on Firefox for the first time I got this:
Incorrect API key provided: sess-0ys*********************************J9J0. You can find your API key at

I had this same error on two different computers. It’s possible that being logged in to both at once was the problem? When trying to generate an image I saw the message that others are describing.
Accessing my history also returned the “Incorrect API key provided” error on the API call but I only know that from looking at the Chrome dev tools. All that was on the screen was the loading indicator.

Logging out and logging in again did not solve it. What did solve it was:

  1. Logging out
  2. Holding the refresh button down and selecting “Empty cache and hard reload” (Chrome)
  3. Logging in again

When I successfully logged back in I saw that the prompt which I had been trying to generate actually went through each time, even though all I saw was the error. I now have 4 result sets for this same prompt and 4 fewer credits. So I am annoyed about that.

1 Like

Yeppers! I am having the same issue. I am pretty much guessing from the sound of things there is not a solution yet. I will check back soon.

1 Like

I am having the same error on both my usual browser and on a fresh install of Firefox without any extensions and no adblocking enabled, so it looks like the error is on the server.

1 Like

i also have this problem…

1 Like

+1, getting this error even in other browsers. Using Google OAuth to login, have 169 credits on my account, have been using Dall E since the closed beta.


Same error here. Tried logging in and out, refreshing. Didn’t help, unfortunately. Looks like the problem is on the server side.

I can confirm that I am experiencing this same issue with DALL-E.

1 Like

same issue. firefox and chrome

1 Like

(sorry delete by mistake)

basically i’ve queued in here as i’m having same error too

Same error… How can I resolve it ?

Exact same error here too.

lol same here guys. Its quite reassuring and yet slightly annoying that I googled the Error and the first thing that came up here. Was hoping it was me being stupid but unfortunately seems to be a wide spread fairly new issue :frowning: I’ve only been using it for a week and was really enjoying it. I’ll be lurking closley for any fixes found! Cheers guys!