Error after editing prompt and submitting again

How come that sometimes you get “Something went wrong, please try reloading the conversation.” when editing a prompt and submitting again. Only happens sometimes.

if I put the exact same prompt in a new chat, it’s fine.

(I have Plus)

The result of getting 100+ million people in a month or so using a state of the art large language model that requires tremendous resources to deploy. Don’t worry. It will get better, I’m sure.

What do you think of ChatGPT? How are you using it?

1 Like

… are you a bot? Your reply feels generated ngl

Anyways: I have plus, I don’t expect issues like this. I’m not getting these errors if I make a new chat. it’s specifically editing an existing prompt.

I suspect that you may be unaware that the issue arises when you wait a few minutes between actions, causing the connection to time out.

To prevent this, I have developed the habit of clicking the browser refresh button whenever I take a break longer than a few minutes. This usually prompts a notification about the server being overloaded,


after which I proceed with my edits and submit them.

Likewise, when deleting conversations, I delete one and then refresh the page to ensure that I have an updated view of the server’s data.

Congratulations, you are not a bot.

I don’t think that’s my issue either because I’ve only manually refresh the page and tried again and it still happens

1 Like

These often happens in ChatGPT when the session expires and it not a function of ChatGPT versus ChatGPT plus; it is a function of when a user has logged in and their login session has expired. Refreshing (reloading) the past and the session timer refreshes.

Plus is primary a server side upgrade. The session management issue you are seeing is mostly a client side issue.

Correct @EricGT

I’ve never seen this problem after reloading a page, unless I leave the session open and come back later after it has expired.

If it happens again @Thibaultmol, you might consider opening your web developer console and looking for console error and at the session vars before you reload again.


I agree with this as the primary next course of action:

Also I have more questions to find the root cause.

Some terminology first, so there is no misinterpretation in understanding.

Conversation - a sequence of prompt and completion for single entry in the left panel

Tokens - Tokens can be thought of as pieces of words. Before the API processes the prompts, the input is broken down into tokens. These tokens are not cut up exactly where the words start or end - tokens can include trailing spaces and even sub-words. (ref)

There is a limit to the number of tokens for a prompt and completion that follows. It is suspected that it is either 4000 or 8000 for ChatGPT.

Are your prompts and or completions large?
Is the last prompt or completion before the error rather large?
Does the conversation have more than 7 prompts?
Are you editing a lot of the prompts and then image?
What are the types of prompts you usually do, generate text, ask question, chat, etc. ?
Is there a consistency in the type of prompt before the error?

Sometimes it seems that ChatGPT gets confused and that is the result back.

Most of my ChatGPT prompts are related to Prolog transformations and are very technical in nature. I use to to see the noted problem quite often before doing the refresh before the next action with ChatGPT; I still get the error but much less often now and it seems to be related to when ChatGPT seems confused. I also now limit my conversations to about 7 prompts before starting a new one and try to limit editing prompts and then Save & Submit. For repeated actions like proofreads and rephrase of text I always start a New Chat for just the prompt and then delete the conversation after the first completion.

You also noted that you are a Plus subscriber. ChatGPT Plus uses a faster version of ChatGPT formally known as turbo (ref) but don’t know how much different it is than ChatGPT. As I don’t subscribe to Plus can’t do more than speculate.

I have also noticed that when they update ChatGPT they are changing the wording of error messages.

Before Feb13 version would see this wording of the error


and with the Feb 13 version now see this wording of the error


One reason I think the reload works is do to the nondeterministic generation of solutions. By using a reload a different path during the generation of tokens for the completion occurs. I suspect that the new path can be completed in the time limit or token limit and the one that caused the error either ran out of time or used to many tokens so had to back track to find a different completion.

1 Like

It’s not long or complex. And is immediately reproducible.
See screenrecording:

This happens both in my normal Firefox profile. A fresh profile with no extensions or previous data of any kind. AND in chrome (inprivate)(again with no extensions).

I’m not using a vpn or fancy proxy/dns blocking things either

1 Like

Thanks for taking the time to make the recording but without knowing the actions you took and when I can not understand what was done to try and reproduce the problem.

While it would be great if you redid it using a recorder that showed the mouse and noted clicks and console text entry, also just noting what was done manually with timestamps corresponding to the video would help. :slightly_smiling_face:

The part that really confuses me is at the 10 second mark when the screen changes, what was done to cause that?

Also the options to resolve the problem as a user are very limited, e.g. refresh button, start new chat, change browsers, etc. So even if we learn the root cause, being able to do something as users may be nothing more than a workaround or change of habit to mitigate the problem with no final resolution possible.

1 Like

I changed browsers … like I said in my original post… Regular Firefox, a brand new profile in firefox without any addons or data, and then lastly a chrome in-private window

All I did was start a new chat at
Type ‘chat’
Submit the prompt.
Receive the reply.
F5 to refresh the page. (that’s what happened at the 10 second mark)
Then click on the left sidebar to go back to the same conversation.
Then press the edit button on the prompt. Add something to it. and confirm the edit.
Then it shows the error

Sorry, but it’s almost impossible to read any detail in your screen recording.

Please copy-and-paste the relevant information from the dev console using Markdown triple backticks like this:

# your code and / or data samples

Your console show 1 error, but your video shows a much of warnings.

The errors (both console and networking) are if interest.


What parts should I leave out so that it can’t be misued? (don’t want to post my cookie id’s here for ex)

That is reproducible on ChatGPT (not Plus edition).

I don’t use F5 to refresh, I click the browsers refresh button image. That is something worth looking into.

If I use the browser refresh button instead I get a completion, no error message on screen returned.

Literally does the same thing but ok. (and yes, I already tried that)

So you’re able to reproduce my issue?


I am using Chrome on Windows 10. I log into ChatGPT using a Google account.

Pressing F12 to bring up the Chrome Dev Tools and then clicking the error icon in the upper right to see the Console I do find three error messages.

Right now I would say that you have found a reproducible bug that appears to be with the JavaScript and so this needs to be sent off to the Web site developers for action. I would dig into the JavaScript but my JavaScript is no longer my primary programming language and even if I did there is not much more I can do. What would be interesting is when ChatGPT API becomes available to try those steps to determine if the problem is with the Web page or the backend.

At this point I don’t plan to do much more as you know that you have the steps for a reproducible problem that was confirmed by another that needs to be reported. :slightly_smiling_face:

Running the clean version that does not produce an error message on the screen then checking the Chrome Dev Tools shows no errors in the console.

1 Like