Custom GPTs: This file contains too much text content. Please try again with a smaller file

What is the current text limit for creating knowledge for Custom GPTs? I tried to do it and get this error : This file contains too much text content. Please try again with a smaller file.

1 Like

How large was the file you tried to upload? I think I saw a limit on a total of 10 files, but I haven’t seen any file size limits discussed yet.

1 File, 10MB, however theres alooooooooooot of text inside.

They said that the context limit was 128k on GPT-4 Turbo

Yeah, but that is just the request-by-request context token limit. The files that you upload are presumably translated to embeddings and managed in something akin to a vector DB. There has to be some sort of cap/limit on that, but i haven’t seen anything mentioned as of yet.

You could try a “binary search” deduction approach. Keep cutting the file size in half until it finally accepts that size. Then, break the original file into chunks of that accepted size. It’s a kludgy workaround, but it might keep you moving forward while all of this shakes out.

Haha yeah i will try to do that. Meanwhile i have created a free tools that let u extract your website as the custom GPTs knowledge file ! Feel free to use it, its free !

filescrapper .com


Has anyone figured it out? I’m having the same problem, even with very small files. :frowning:

“This file contains too much text content. Please try again with a smaller file.” Ugh.

I get it too with a 22MB file. I need to do data analysis on it so context should not matter.

Maybe switch file formats. I got “cannot upload” errors for a tab-delimited 33MB file. Splitting to smaller, even tiny files, failed.

But the same data in CSV (comma-delimited) format uploads fine.

(It’s possible the error message is not precise.) Try a different format.


I was forced to split it to ~2MB per text file in order to make it work.
Where is AGI if we cannot even get upload to work ok ? I mean come on! The uploading of the files and the Publishing of the Custom GPT is far for fluent. It is a pain currently. This is not a Beta version, this is barely Alpha. Sorry but not sorry

There’s been no resolution here I assume? I’ve experienced an identical issue and can find no documentation suggesting a text limit. I’m within the file maximum and am attempting to upload a single PDF document as knowledge, but there is a tremendous amount of text within (JSON code).