Custom GPT suddenly cannot save any behaviour changes for new or updated custom GPTs?

Yes, same problem. Cant save anything.

Yep. Same here. “I am experiencing technical difficulties”…

Been trying to update a custom GPT and I’m getting the same errors.

I am so glad to come across this comment. I was wondering if why my plugins don’t work or why I still have no access to the GPT store or why GPT i been creating would not update the behavior or actions I want it to take. I was wondering if it was cause I am just a Plus member and thought maybe I need to upgrade to teams, but I don’t need two seats. Yet, I wondered why would being a paid PLUS user that, that would keep me from the things it states i should get anyhow as a Plus member, esp. for the last almost 3 yrs… I wonder if there is a system issue or just an issue cause they may be updating the system!!! IDK but this is all really effecting my business as well as other things I was hoping to be able to tackle and it’s all been hell. I have had better luck using other Ai tools esp. with Microsoft, but I want to continue to use my ChatGPT, just this is a headache!! lol

Same issue here, no plugins or any other factors that could influence this behavior i have very ‘vanilla’ set up since i’m only starting with gpt. Below is gpt’s own diagnose for the issue.

Issue Description:

  1. Objective: The task was to update the behavior settings of the custom GPT. The specific update requested involved adding a new directive under a chapter titled ‘Behavior’ within the custom GPT’s context. This directive was to ensure that any future behavior-related instructions provided by the user would be documented under this ‘Behavior’ chapter.
  2. Procedure: The standard process involves using a specific tool function (update_behavior) to modify the custom GPT’s behavior context. This function allows for the modification of various aspects of the GPT, including its context, name, welcome message, and other behavior-related settings.
  3. Problem Encountered: Upon attempting to update the context with the new directive, a technical issue occurred. Despite using the correct method and syntax for updating the GPT’s behavior, the system repeatedly returned a ‘TypeError’ exception. This indicates a problem in the underlying system’s ability to process the update request.
  4. Attempts to Resolve: Multiple attempts were made to revise and resubmit the update request, including rephrasing and restructuring the content to be added. Despite these efforts, the ‘TypeError’ persisted, preventing the successful implementation of the requested changes.
  5. Current Status: The issue appears to be a technical limitation or bug within the update_behavior function of the system. This is not due to user error or incorrect usage of the system. As of now, the requested update to the custom GPT’s behavior settings could not be completed due to this internal system error.
  6. Impact: This issue limits the ability to dynamically update the behavior context of the GPT as per user requests, which is a key functionality for tailoring the GPT’s responses and capabilities to specific user needs.

I recommend including this description in your message to support, as it outlines the problem and the steps taken to resolve it. This information should assist them in diagnosing and addressing the technical issue more efficiently.

Same issues with my custom GPT updates.

I have noticed that in some instances, even after failed update attempt due to technical issues is declared, the previewed GPT title and/or descriptive role will update along with other information as seen in the Config tab. This implied contradiction is vexing. I realize that simple updates like an icon change don’t necessarily qualify as a behavioral “configuration update.” But the ambiguity makes me lose all confidence in the process.

I’m afraid to even attempt to update an already customized GPT, for fear of overwriting/losing valuable characteristics. I suggest experimenting with creating and implementing changes to a new “dummy” GPT until confirming that they have fixed the issue.

In the meantime, I have been simply updating my GPT via regular conversation. Within the context window of the conversation, it will retain the information and behave accordingly (differently, based on your prompt) for subsequent discussions. It’s effectively a temporarily updated GPT. You can also ask the GPT to describe what configurational changes might be useful for GPT Builder in an attempt to capture what was “learned” in the current conversation. When GPT Builder is restored, you can paste in those updates and apply them to the core configuration.

1 Like

Yep, it’s persisting:

" It seems we’re facing a persistent issue with the update. I’ll troubleshoot this to ensure the enhancements you requested for the PTO Planner are correctly applied. Let’s give it another try.

It appears we’re still encountering an issue with the update. I’ll take another approach to resolve this. Please hold on for a moment.

We’re still facing some technical difficulties with the update. I’ll make another attempt to ensure the PTO Planner reflects the enhancements you’ve requested. Please bear with me."

1 Like

Do you remember what prompt you used to get that information? I’d like to use it on my GPT and see if the issue is the same.

I’m getting the same error now, none of my GPTs can be updated.

1 Like

I’m not able to upload any files as of about 10 minutes ago… All file-upload attempts sit there, then show a message that the upload failed.

1 Like

Thanks for posting. I’ve been having the same issue for several days.

2 Likes

Having the same issue updating our GPTs. Hope this gets updated soon.

1 Like

If they’re working on it, if it’s a difficult issue, they should at least give a status update, no? I’ve been having issues with it for days, now. J

1 Like

same issue for me. is there any place where we can monitor issue resolution for this kind of problem?

1 Like

FWIW, I did log a bug report on Discord, there was another person asking about the same issues today. Hopefully, bringing more eyes on to this helps get the issue fixed. Also filed a bug report via the help chat on the website.

1 Like

It is glad to see you are having the same problem, that means I am not the only one who is struggling with the GPTS. I think I have been unable to update anything for a week or so. THe builder will just say: “Unknown Technical Problems.” So have you found any solutions to this problem?

sometimes using updating behavior using conversation doesn’t guarantee a satisfied result. It seems some times the GPT will forget what we’ve been talking about.

1 Like

Here also. Even the most simple updates regarding request or response transforms raise a TypeError in gizmo. Yesterday it worked, but now it seems stuck. Also, creating a new GPT gets stuck in the beginning.

Can you help me?
I am continue getting error on my Custom GPT Review. Please help me.

Yep, thought I was the only one ready to knock my monitor in the floor :melting_face:

Depending on the prompt, I’ve noticed that it will still do whatever I promoted it to do but it seems as if it’s unable to respond without stating it encountered an issue of some sort :unamused: