Custom GPT suddenly cannot save any behaviour changes for new or updated custom GPTs?

I am also experiencing problems, ANY time I try to attach a file to knowledge it just says “Error saving GPT” then for some reason if I try to update any custom gpt that already has knowledge attachments it also says “Error saving GPT”

2 Likes

Suddenly the file attachments are working but it only saves to the preview, I don’t know why but just doesn’t want me to actually publish gpts with knowledge sources.

2 Likes

i’ve ben getting the exact same error since last night trying to upload a simple PDF (32kb) with a numbered list in it (1 - 50)

1 Like

Same here, with everything. For me it says it keeps getting “TypeError”

I can’t even do text files, it’s definitely just a chat gpt bug, they will probably fix it, but then again, considering the current state maybe not…

1 Like

I didn’t get a chance to read all of these, but here is my take. Open AI seems like the do not want anyone getting emails or making money with these as of now. Also, if someone said it, I missed it, but I did notice that someone was having a problem I think because to have a website involved as the creator and not yourself, you need a privacy policy. And lastly, they are messing around! This is all experimental. I have a feeling they are sitting back and seeing who is using what they got, and creating something cool or good. I just made one in five minutes, and I can see kids and people having a ball with it for hours. I will show screen shots. Just look at the instructions, the content, and the input. If you want to make money and all that, you need to go the assistant and python route, its just true. or pay someone else who built a ‘code free’ maker.



1 Like

Apparently it hasn’t been fixed overnight… Here’s the GPT’s response:

“While the technical issue with updates persists, your input is valuable in shaping the desired behavior of the GPT…”

Okay, it appears, at least for me, that Google Chrome was the issue. I couldn’t use any GPTs or even run any regular ChatGPT 4 chats on Chrome, but Safari actually did work fine on my Mac. I just updated my Chrome and now I can run regular chats, my GPTs can be edited and saved cleanly, etc. Mine appears to be back to normal. Chrome Version I updated to is noted below. So I would recommend others see if that helps solve their issue. Hope it does.

Chrome is up to date
Version 121.0.6167.85 (Official Build) (arm64)

1 Like

Same here. It does not work for any update of GPTs make the whole builder useless. I’ve already submitted bug to OpenAI support, but I’ve got the information that the answer will be in 3 days.

After having the issue on Chrome all week, it finally started working this morning but soon stopped. I tried moving over to Safari, but that also stopped working after a while.

I’ve had the issue for the past couple days now as well. I’ve been busy with school lately so I started creating the GPT last saturday and left it until yesterday and it wouldn’t work. So my initial thought is that it needs to be restarted since its been sitting on the same page for a while. I restarted it and nothing, so I created a new gpt yesterday as well, and still, nothing will load so i’m pretty sure its a recent bug which prevents things from updating. I will try Safari and see if it works for my mac @djohnson2 but chances are it’s just a bug that can only be resolved my waiting.

Hey Guys can confirm I am getting the same issue.

I’m getting the same issue - quite frustrating, my GPT makes the same consistent error every time I test it, I give it what should be the correct answer, it then tells me that a technical issue is preventing it from updating the behavior, and continues to make the same error. It’s a public GPT so the incorrect behavior could definitely have effects on users. I guess I’m at least perversely heartened to see it’s not just a ‘me’ issue

I wonder if the browser difference was just coincidental and it had more to do with just being in a different session.

1 Like

Just want to let you know, that I have the same issue. :confused: Hopefully OpenAI fixes this soon.

Same problem here … “I apologize for the inconvenience. It seems there’s a persistent issue with updating your GPT’s behavior. For now, I’ll manually adjust my responses to include your request. Let’s proceed with this approach. If there’s anything specific you’d like me to work on or any particular change you have in mind, please let me know!”

1 Like

Ive had the same responses as everyone else here. From what I found, the changes you attempt to make should still work with the Preview next to the create chat, but it will not permanently save the changes. So they will work in that singular session, but not any others.

1 Like

Having the exact same problems. Started on Tuesday evening.

I am having the same issue. It won’t update behavior for my GPT all of a sudden. I’ve tried restarting my computer and still get the same issue.

1 Like

Same here since Tuesday / Wednesday this week: “It seems there was an error while updating the behavior.”

Tried it on different laptops with different browsers, no success.