Custom GPT no longer working

I have been playing with my own custom GPT when now suddenly I get the error “Hmm…something seems to have gone wrong.” Whenever I give it an input. It started after I uploaded a PDF into its knowledge base, I’m not sure if that was the cause. However, Even after removing the PDF I still get the same error when trying to use this GPT. All other GPT’s I have tried (Those created by openAI and general GPT chats still seem to function. Anyone else having a similar problem?

8 Likes

I have a similar problem, when adding more than one file in the knowledge section. Exactly the same behaviour, but when I leave only 1 file - it works.
I have played around with adding different files like txt, md, xlsx. And I’ve found that if I upload md files, I can upload 2 or probably more md files (still testing) - they are indicated as “Files” not “Documents” then. I also have my “Code Interpreter” turned on and instructed my GPT to retrieve the uploaded files first, then search the Internet when needed. And it seems to work. But if I add “xlsx” and “md” files - it stops working again. Seems like having problem addressing more than 1 file or more that 1 file extension…

UPDATE: I have found something that also might be related. When I go back into the editing mode, sometimes I can see in the upper right corner of the page a message “Unpublished changes”. It doesn’t disappear even after I click “Update”. And then 99% the bot gives “Hmm…something seems to have gone wrong.” message with my every input. But when I hover over that message “Unpublished changes” and click “Undo” and then “Save” - it works again, with the same data, settings and files uploaded.

2 Likes

I am glad I found this post… I have the same problem… I uploaded multiple PDFs to the knowledge base and it worked fine for the first few, then it just kept spitting out errors so I removed all but 1 and it started working again.

Me too… I just lost 5 hours trying to group my knowledge in different ways and files types. This approach helped me progress again! THANK YOU. Hope they fix it soon.

Same issue, and I’m also seeing the unsaved changes dialogue. If I hit the undo button, it seems to fix the issue (at least for now).

I just used a .pdf combiner and it seems to have fixed my issue.

1 Like

Wow this worked. Must be a bug. Hopefully they’ll fix it but for now this is working for me.

1 Like

Same issue for me. I can save the schema once when I create it, but can’t ever save changes to it.

I get the same error message but not always. Not sure if the problem is in the PDF or if the system just fails sometimes. Now, I have been able to upload two PDFs.

I was able to get my GPT to save after merging 20 C# files into one file and calling it all-code.cs. I was able to talk to it in edit mode, but then after I published it, it stopped working. I get the “Hmm…something seems to have gone wrong.” error.

Clearly this release is buggy and probably should have been more thoroughly tested.

EDIT: Now it won’t talk at all with the all-code.cs file included (which is only 76kb). I’m not even sure this service is usable at this point. This seems like a basic requirement of intent.

It seems to be working now. We’ll see what it remembers as I prompt it.

EDIT: Whatever they did seems to have opened it up. My GPT is working (so far) as I expected it to.

same and more problems updating the knowledge base.

I have the same problem. I keep uploading a document an it disappears when I try to edit the custom bot again.