Custom GPT: API key needs to be added each time; how to use is_consequential

Two issues I am having with my Custom GPT:

  1. Every time I update my API schema, I have to update my API’s API key. Is there any fix for this or is this a feature?

  2. Even when a user accepts using my API from the GPT, it always asks for "Confirm"ation. How can I make it work “always”. I have done a bit of research and I think it has to do with the is_consequential flag, but I am not sure how to implement it. Is it something I can add to the schema.json? If so, where? If not, what else can I do?

1 Like