ChatGPT web UI bug - ChatGPT responds to suggested prompt instead of user input (Edit: Seems Opera Browser related)

There is currently a UI-related bug in the web version of ChatGPT.

How it’s manifested:

The user will type a prompt, and press the enter key. Instead of receiving a reply to the user input, ChatGPT responds instead to one of the ‘suggested prompts’ that were recently added to the UI.

There are videos of it happening in action on Reddit. You can see the suggested replies visible that ChatGPT replies to. I am apparently disallowed from providing links in hyperlink format…



Add reddit dot com to the beginning of the URLS to see them.

In both linked videos, you can clearly see that ChatGPT is responding to the top left ‘suggested prompt’ instead of what was typed. When the user posts the chat link to the chat, that prompt appears in the history, not what was manually typed by the user. In the first video, you can see that ChatGPT responds to the suggested prompt, ‘Explain airline turbulence’ instead of the typed input. In the second video, you can see that ChatGPT is responding to the suggest prompt, ‘give me ideas for what to do with my kids art’ instead of the typed input.

In both examples, it was the top left suggested prompt that was answered.

There have been dozens of examples of this that I’ve seen on Reddit lately - the above two links are examples with video capturing the bug in action.

1 Like

If someone can cause this bug to happen again and capture the network activity, that may shed some light on if it’s a front or back-end issue.

Noticeable patterns:

  • Free accounts
  • “Already typing message” error pops up momentarily

There is a theory that it might happen when the mouse is hovering over the suggested reply when the ‘enter’ key is pressed, which would make it a UI glitch, but I am unable to reproduce that myself. It might be a browser or OS specific issue in that case.,

1 Like

I like this theory. The two videos have these weird sidebars on their browser. Wtf is that?

Some sort of browser plugin, maybe? I recognize Whatsapp, email, and Twitter icons there, I think. I don’t see that in the other video.

1 Like

The other video only shows it momentarily and in terrible quality

From the current top comment that captured it on video (different Reddit users)

Ah. I am messaging the user to ask.

I think your/their theory is pretty good. Besides the mouse hovering part. I don’t see that in either of the videos. Also, there is only a click listener (button) on the suggested prompts. One interesting thing to consider is that they are all wrapped by the same form.

I watched the full video and saw how the original message is also overwritten. The fact that the error message also appears for a split moment makes me think that for whatever reason the “suggested prompt” kind of hijacks the prompt, causing the “already typing” error to appear. Two messages are being sent.

Each message is independently cached so it makes sense that the actual message is typed out, while the original message (which doesn’t actually exist) stays until the page is refreshed

Yeah, the theory about the mouse hover came from one of the users who had the bug. Rewatching the other video, I can see the mouse isn’t over the suggested prompt. Still think it’s a weird UI bug though.

I know some mobile users had issues with the suggested prompts covering up some of the UI elements…

Using the current theory I tried to replicate it:

// Suggested prompt
const $a=document.querySelector(".grid > div:nth-child(1) > div:nth-child(1) > button:nth-child(1)");
// Submit button
const $b=document.querySelector("button.absolute");

// Execute asynchronously
(async () => { $;$ })();

[HTTP/3 429 Too Many Requests 163ms]

[HTTP/3 429 Too Many Requests 153ms]

I don’t think the clicks actually can be asynchronous though… Whatever

I saw the same rapid “wait for message to finish typing” message, but I got my prompt’s response and not the suggested.

Even when I reversed it I still ended up with my prompt.

Nevermind. I got it to occur

Coke and pomegranate sounds pretty tasty

On refresh:

Well done! Hopefully someone from OpenAI sees it. I looked for ways to submit a bug report before posting here, but couldn’t find a way to do it!

I think it’s only fair since you brought the attention here that you send this information (if you want) (& if it’s applicable) to their bug bounty program. I won’t do it but you can include what we’ve found here I have no issue with it.

1 Like

Thanks, I’ll think about it. I don’t think it’s a security bug, so probably not eligible for bounty. Thanks anyway!

I believe both Edge and Opera use the sidebar? If you’re interested in digging deeper.

I noticed one of the user’s that reported this issue is being flamed for faking it so here’s a video of it happening using the code so others can replicate it. I am wondering if this is a silly “feature” of Edge or Opera.

1 Like

Hey there, I’m the Reddit user that made the second post with the video.

For those asking, the sidebar comes with the Opera browser. You can toggle different sidebar options like social media sites and two different AI chatbots. ChatGPT is obviously one of them.

Back to the main point, before I left for work today (around 5h ago) I was able to recreate the bug if I hovered over one of the suggested prompts and hit enter. However, now that I’ve gotten home, that no longer works. I have been trying for the past 15 mins, yet I cannot recreate my previous results. Could this be a sign that it was fixed?

Which video? Both that we have discussed don’t show the cursor hovering the suggested prompts.

Thanks for letting us know. I was just able to reproduce the error (in 4 tries though. first come first serve) so not fixed.

Thanks for your testing on this. From the examples I’ve seen in the wild, at least the ones in which the suggested prompts are visible, it seems that the suggested prompt that gets answered have all been the top left one.

I highly doubt it would be an intentional ‘feature’, but it may be some sort of browser compatibility issue at play. Who knows how much testing OpenAI did with the regards to compatibility with browsers like Edge or Opera.

The flaming and accusations of faking are what annoyed me to the point where I posted it here. There have been posts about it on Reddit almost every day since the suggested prompt feature was added, but the problem was that people only took screenshots after the fact, and the ‘share conversation’ feature doesn’t show the original user’s actual prompt. Invariably that leads to accusations of lying (for some unexplained motive), because people can’t wrap their head around the fact that a legit bug might exist, and everything must be the result of bad actors or whatever. Everyone’s so quick to jump to conspiratorial thinking these days, it seems.

The comment that really irked me that urged me to spread news of this was the comment by the guy in that post saying Occam’s Razor suggests that the best explanation was that the poster was lying. As if dozens (if not hundreds) of people faking GPT screenshots was somehow a simpler or more likely explanation than a simple bug.

Fortunately, today, two Redditors managed to capture video of it happening in real time, so hopefully this can be fixed and put to bed, because I’m frankly tired of seeing the same cycle repeat, along with all the flaming, etc.

Given how many examples I’ve seen of this happening on the ChatGPT subreddit, I was initially shocked how long this bug has gone on without being fixed (in relative terms, of course)… until I tried to look for a way to file a bug report. Here I am, posting on a community developer forum, hoping someone from OpenAI sees this, because as far as I can tell there isn’t a simple ‘report a bug’ feature, which is honestly a little shocking. All the support links I could find were for support with billing/accounts stuff, etc, not technical support. I remember when ChatGPT was first released for free, it was described as an ‘open beta’, and the free tier still might be considered to be that, but beta testing really only works if there’s a way to submit feedback.

Do paid users get a support channel that free ones don’t? I’m a free user myself, though I pay for Poe, because it gives me GPT4 access as well as the various other models to use, supports file upload and link support, and its custom bot feature is better implemented than custom instructions is with ChatGPT, etc.

1 Like

Yeah. The only thing I can say for certain is for some reason that suggested prompt + the actual prompt are being both sent at the same time(ish). The fact that it seems to be intermittent (in the videos, in my testing it was whichever was received first) is odd but truthfully (don’t mean to sound rude) I don’t care enough to start downloading Opera and testing further. I’m not saying that it’s something to with Opera, that’s just where I have left my train of thought.

Yeah… Pretty wild. What the hell is wrong with those people & their useless, negative comments.

Certainly seems that be that way. More compassion for AI than their fellow people.

Hilarious. Hope the best for that person and their detective skills.

No, and nobody here can help you communicate with OpenAI, nor will they bother responding to this here. I’ve heard Discord has better chances, but that’s just what I’ve heard.

Atleast now we have a way to reproduce the error, so they can scuttle elsewhere for their collective harassment routines

1 Like

I am the creator of “/r/ChatGPT/comments/161ki1h/wtf_just_happened/jxthn7y/”.