Can't buy credits in DALL-E

Hi, I’ve been trying to buy credits for DALL-E but when I click the button (labs DOT openai DOT com or labs DOT openai DOT com SLASH editor) it goes to a blank white screen. i’ve tried in Firefox and Chrome.

Firefox and derivatives is broken for both platform.openai.com and labs.openai.com.

Chromium:

  1. Have a payment method on file, and be logged in;
  2. and then type in the url for labs.

image

All the way to “complete payment”.

The question is about the white screen the “buy credits” buttons take you to. It is not clear which browser people use who do manage to get a functioning DALL-E credit screen. I did not in Microsoft edge or Chrome just now. Both gave non active purchase screens. I can buy credits personally in the OpenAI account, in a corp account but not at all for DALL-E personal or Corp account. Seems the UI is not working for some browsers.

Hi, have the same issue.
Tried few browsers - Chrome, Brave, Microsoft edge on win 11, also chrome and safari on ios 17. Chroome extension also dont work. When i click on “Buy credit” shows me only white page

2 Likes

I get all the way to “complete payment” with my API credit card payment method pre-entered.

Try this path:

  1. go to openai.com and press login,
  2. authenticate, select API, and be taken to your account,
  3. type labs.openai.com in the URL bar of that window.
  4. spend money

still not working.
did anyone sucesfully buy it in the last few weeks?

labs.xx is made semi-redundant by the API now, except for those that thought that it produced better DALL-E 2 images than the API.

The 115 credits cost 13.5 cents each.

With API, the most you pay is 12 cents for the highest resolution and HD mode of DALL-E-3 (and two cents for max size DALL-E_2).

At least their web price never encroached on your ability to make a bit of profit reselling the API product in a useful interface - until they gave it to Microsoft Bing for free.

yes, but how can i outpaint an uploaded image now?

I have tried, Chrome, Safari, Edge, and Firefox, and every way I try to buy credits it’s just a blank white screen. I have gone through the account, the front page, and the circle with my face, every screen time it’s just a blank white screen and I have restarted all my devices. Does anyone know how to purchase more credits?

2 Likes

Its a bug. I fixed it locally with the browser console and purchased credits.
But it was not easy to do that. OpenAI should fix it.

1 Like

I’m in the same situation. Could you provide some detail on how you fixed it in the console? When I try to profile it, the only failed request seems to be a rate-limit one (429) for sentry (e.g. from the response detail)
Sentry dropped data due to a quota or internal rate limit being reached…
Not sure how this would result in the white screen.
TIA

My error in console was something else. Some property that was read was not defined, I just defined it and then it worked. I think our issues are not related.

1 Like

Makes sense that different errors would have different solutions. Thanks for looking into it!

I have been having this problem as well. I have tried Firefox, Chrome, and Edge on Windows, Firefox and Chrome on Android, and Firefox and Safari on my iPad. The result is always the same…blank white screen as soon as one clicks the “buy credits” button from any location on openai.com that displays the button to purchase credits. Refreshing the blank white pages redirects me back to the page with the “buy credits” button, whatever origin page that was. No amount of waiting on the white page results in anything but the white page being displayed.

2 Likes

Did it happen to be disable_all_events? I’ve gotten it so that that’s my only issue left, but don’t know how to solve it from there. TIA!