Authorization error accessing plugins in ChatGPT Plus

As today august 8th any plugins enabled throw the same error. ChatGPT is usable only without plugins. I’ve tried all the solutions before, even logging into single plugin site but nothing. completely puzzled…

1 Like

I am having sam problem just now. I also tried to reinstall plugins from Scholar AI, then installed again. But that was not a solution.

1 Like

I encountered this bug after attempting to use a plugin during a stale session. Specifically, after leaving ChatGPT idle in my browser for about 16 hours, I tried to use the “ChatwithPDF” plugin. Typically, a dropdown button appears to show special processing within the plugin, and it would either complete the request as normal or in case of a network error it would terminate the thread, returning an appropriate response. However, in this instance, the plugin started a thread but failed to respond.

I suspect the issue arises from an authentication process to verify the user’s license before allowing plugin use. My session on the server had timed out, but this wasn’t recognized client-side. When I initiated a new prompt, it seems the request used outdated validation tokens. I believe there might be a server-side bug that processes this “anonymous” request up to a point, even starting a dedicated thread for the plugin. But due to incorrect authentication credentials, it hangs indefinitely. This hang prevents further use of the plugin in the same thread and causes ambiguous permission errors in new threads, as the server might interpret this as a permission issue rather than a stalled thread.

In my situation, I tried deleting the offending chat session and removed the plugin. But upon reinstalling it, the server had an error re-initializing the plugin with my session. I suspect the plugin’s zombie thread is still registered in some way to my account which is preventing it from initializing properly.

Note, I’m not a ChatGPT developer but I have developed many web applications and this theory is based on my own experiences, so I think it’s worth investigating.

Currently the zombie plugin is completely inaccessible to me. My hope is that there is some kind of watchdog timeout on these threads or there is a “spring cleaning” to kill them off as part of a maintenance. Either way, this issue certainly requires quick attention.

I am not even able to download it, it just come up that “Couldn’t log in with plugin”

2 Likes

I also get “Couldn’t log in with plugin.” - tried different browsers, incognito, tried to delete the app but cannot add it back in…

2 Likes

There is a global issue with oauth currently see https://community.openai.com/t/plugin-oauth-token-flow-may-have-changed-error-forwarding-auth-message-int-object-has-no-attribute-total/318724/12

Thanks for letting me know Aurelle :slight_smile: As i didn’t see any incidents in status page didn’t know if it was a generalize issue or not!

I have the same issue here, hoping for a resolution soon!

When using the ScholarAI plug in I have the same issue. Doesn’t matter how often i am logging in or out. I hope this gets fixed very soon.

If anyone gets this exact issue, the problem occurs when a plugin that didn’t support Oauth authentication moves to Oauth authentication.

This transition is not handled at all by chatgpt and it results in a failure for all users who installed this plugin before Oauth was configured for it.

So to resolve it, just follow these steps:

  1. Open the plugin store and go to installed plugins
  2. Search for the plugin that does not work
  3. Uninstall this plugin
  4. Reinstall it

If it still does not work, it’s most likely a temporary problem with ChatGPT

Hope it helps.

1 Like

having the same issue today. have logged out/logged back in. have uninstalled ALL apps and reinstalled just those i need for session. still getting “Authorization error accessing plugins” message.

2 Likes

Hey!

What plugin was not working exactly?

@kevinpiac
TotalQuery Search
Web Requests
ChatWithPDF
AI PDF

2 Likes

Same here and reinstalling and therefore authorizing again worked.

Hello everyone,

I’m currently experiencing the same problem with all plugins that require authentication. Uninstalling/reinstalling doesn’t change anything, including changing browsers.

I’m one of the alpha testers.

@OpenAi ?

I expereienced this errore while trying to download Plugin which requires authorization : “Couldn’t log in with plugin.” It happened for “ScholarAI, SmartSlides ecc.”

2 Likes

We have the same problem then. It’s been going on for over a week on my side.

Maybe wiping cookies from the websites application data (in the developer tools when accessing chat.openai.com) could help here.

Negative. I even tried with Firefox Developper Edition. No luck.

However, I found the source of the problem. This problem only occurs when I activate the apha test version. In beta or normal, no problem @openai

In my case (Portuguese Alpha) I just changed the language to English in the profile:

Settings & Beta > General > Locale (Alpha) en-US

1 Like