Api Keys referencing wrong organisation

I’m part of two different organization accounts. One has hit rate limits, the other has not. I’ve tried to switch over to the other organisation, generate a new API Key and run with that instead. Despite doing this and changing the default API organization,

At first I was getting this error returned: You’ve exceeded your current monthly quota on OpenAI’s API.

I am getting now getting this error message for the same API key:

OpenAI’s API returned: "Incorrect API key provided: sk-ndSgX***************************************u1Cm.

I have tried creating and using additional secret keys, all of which authenticate successfully but I still get this response.

Two accounts for the same app … to bypass rate limits?

I’d reach out to help.openai.com

Good luck.

You can include the organization ID as part of the API request to bill directly for every request. That will override the “default” and make clear where the key usage is being billed.

Then you just must be a member of that organization to use it.