API key does not work, I have tried all the methods and hacks I can find

API key does not work from Python, I have tried all the methods and hacks I can find, including setting within Python, clearing my cache setting env variable, and everything that is suggested.
My OS is Ubuntu 22.04 and my Python is v 10. Any further suggestions gratefully received. Thank you

If you have more than one organization, select the correct default organization after creating the API key.

Thank you so much for your rapid response. I have tied your suggestion but I am still getting the ‘Key error’ message

Are you getting this key error response from all API endpoints or just a specific one?

I don’t write in Python, but why don’t you post your code here (or a link to it in your Github/Pastebin) and someone might be able to help you figure it out?

Do NOT include your API or Org keys in any code examples

Thank you for your suggestions. However, it seems I was too impatient. About a half hour after I made the most recent of about 5 API keys, the latest one worked correctly.

1 Like