3 GPT Plus Charges, no refunds and still no Plus

My subscription to plus failed to charge as I got a new card and didn’t update. I never received a notice that it failed, and wasn’t told that my plus sub had ended.

No big deal, just went ahead and upgraded. Did it once and nothing changed. I was charged but no plus, I tried two more times. So no I have paid $60 over a week ago and still do not have access to plus.

I emailed support at refunds and received no response.

I just want to use the tool. Please help!

I’m having the same issue. I also created a few tickets and in 3 days I haven’t received any response. Not even an acknowledgement whether they are looking into the issue or not. This is getting annoying and approaching the point where I don’t feel like paying for Plus anymore. @ OpenAI please fix this or at least acknowledge the ticket we create so it doesn’t seem like they’re going into a black hole.

Here’s what my main ChatGPT app window looks like:

Notice that there’s no option to select between GPT 3.5 and 4 on top like there is for Plus users. Also the bottom left of my app window looks like this indicating that my Plus subscription is not being applied:


Here’s what I see when I click the “Upgrade to Plus” link:

And here’s what I see when I go into my subscriptions page:

This is a known issue, openai team working on it to fix it.

Read this article for more info: Why is my Plus subscription not appearing? | OpenAI Help Center

1 Like